• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Moderation queue and Permissions

Skylined

Active member
#1
A user has created a new album and added media to it.
He's in the primary group called Registered.
He's also in secondary groups Introduced and User.
Groups Introduced and User have all permissions set to Not Set.
Registered group is set to allow Bypass moderation queue when adding media
Now the pics show up in the Moderation queue.

I want to let users create and add media without having to approve anything.
Am I missing something? :unsure:
 

Chris D

XenForo developer
Staff member
#4
Assuming you have run Analyze Permissions against the user who had their media put in the Moderation Queue, what you're saying just isn't possible with those permissions.

Are you sure none of your moderators have "Unapproved" the media?

You could check the Moderator Log in the Admin CP for entries like this:

upload_2015-1-26_3-23-50.png
 

Skylined

Active member
#7
This is weird, the Posted By field is empty.
Then when I click on the image link, in the Uploaded By field says Deleted User
When clicking on the album link it says that no media has been added yet.


upload_2015-1-26_1-39-45.png upload_2015-1-26_1-43-23.png upload_2015-1-26_1-45-14.png
 

Skylined

Active member
#9
This is the first time that this happens, that same user has even uploaded another album some days ago without any problems.

@Maru I'll do that tomorrow.

Thanks for your help guys. :)
 

Chris D

XenForo developer
Staff member
#12
Is it only happening to this user?

Is it possible for me to get access to your Admin CP and also that user's account?
 

Chris D

XenForo developer
Staff member
#14
At the moment, it all appears to be working correctly.

The items that are in the moderation queue, can they be deleted? The user may just need to re-upload them.
 

Chris D

XenForo developer
Staff member
#17
I can have a look at sorting this out, but it's going to need some level of access to your database. It might be best if you submit a ticket from the Customer Area with details. Just for good measure, please make the forum account you have already created for me into both a Moderator and an Administrator (with full Admin permissions). In addition to that, access to your database using PHP My Admin will help me resolve this.

I think I should be able to do this without having to delete those items.

Please, however, before you do that, take a back up of the database.
 

Skylined

Active member
#18
My host is having problems with the backups, that's why I haven't replied yet.
I'll let you know as soon as I have a backup.


Today another user created a new album and uploaded some pics, and in that new album there are a couple of pics from the other user that was having problems.


It says that the album contains 3 pics, but then...


upload_2015-2-1_1-36-2.png upload_2015-2-1_1-37-28.png