1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 mkdir() [<a href='function.mkdir'>function.mkdir</a>]: Permission denied

Discussion in 'Installation, Upgrade, and Import Support' started by mdj101, Feb 12, 2015.

  1. mdj101

    mdj101 New Member

    I'm installing on a windows server and have enabled full control on the two folders for IUSR but im still getting the above error.

    Any ideas?
     
  2. Mike

    Mike XenForo Developer Staff Member

    What's the full error? If it's an install, it shouldn't have let you proceed until the permissions were correct.
     
  3. mdj101

    mdj101 New Member

    Server Error
    mkdir() [<a href='function.mkdir'>function.mkdir</a>]: Permission denied

    1. XenForo_Application::handlePhpError()
    2. mkdir() in XenForo/Helper/File.php at line 139
    3. XenForo_Helper_File::createDirectory() in XenForo/Install/Model/Install.php at line 579
    4. XenForo_Install_Model_Install->createDirectories() in XenForo/Install/Controller/Install.php at line 439
    5. XenForo_Install_Controller_Install->actionStep2() in XenForo/FrontController.php at line 690
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 267
    7. XenForo_FrontController->run() in D:/vhosts/xxxxxx.co.uk/httpdocs/forum/install/index.php at line 35
     
  4. Mike

    Mike XenForo Developer Staff Member

    If you go back to step 1, it doesn't give an error about permissions?

    It seems like it's saying that you can write to the directory which implies that you should be able to create new directories within, but when you actually create those directories, it's erroring. There may be some more advanced permission configuration setups in Windows that could prevent that. Make sure that the full control is being inherited to all sub directories and files (it should be on the "advanced" permissions page).
     
  5. nrep

    nrep Well-Known Member

    If you're still stuck you may be able to capture more information about the access denied error using Process Monitor (https://technet.microsoft.com/en-gb/sysinternals/bb896645.aspx). It should show you which user requests permission, to confirm that everything is set up correctly.

    Are you using a control panel like Plesk or Website Panel?
     
  6. mdj101

    mdj101 New Member

    We have plesk installed but I have root access which is where I do most things.
     
  7. mdj101

    mdj101 New Member

    It's set up as This folder, sub folders and files.
     
  8. nrep

    nrep Well-Known Member

    Have the permissions been inherited correctly? Plesk has an option to allow additional read/write permissions per domain, you could test enabling this and see if it works - then check out how the data and internal_data directory permissions are set up if it does.
     
  9. mdj101

    mdj101 New Member

    OK, I've managed to get round this by setting the permission on the two folders to EVERYONE and it's installed. However I don't really want to leave it like this.

    It's obviously an issue with IUSR account but what I have no idea.
     

Share This Page