1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Messed up with message template I think...

Discussion in 'Styling and Customization Questions' started by iGloo', Mar 7, 2014.

  1. iGloo'

    iGloo' Member

    Well... That's how my forum looks like when I go on any post... http://prntscr.com/2ysvvj
    You can see that my text is under the message_user_info block, I restored all the templates I was working on, but I still face the same problem, I would like to put it as normal (top), I hope someone here would be able to solve this problem!
    The fact is that I was trying to put my user info block outside of the box, like this: http://prntscr.com/2ys8mv
    I would like to know where to go and what to change to do what I said.
    Again, if someone have the answer, that would be fabulous. *-*
    Thank you in advance!
     
  2. Russ

    Russ Well-Known Member

    It's hard to tell without seeing the site.. but that look you're trying to achieve is fairly easy.

    Content BG on the thread page needs to be gone/same color as page background.

    Simply add padding to the .message .messageInfo style property + border/box-shadow.


    Screenshot_2.png
     
  3. iGloo'

    iGloo' Member

    Thank, it makes sense. I will try and contact you if the problem persist. ;)
     
  4. iGloo'

    iGloo' Member

    Well, this is a bit better, but it looks like that: http://prntscr.com/2ytxl7
    I would like to remove the border and add a border around the textbox and add a line te separate each posts... :)
    Thank you in advance if you can help me.
    (I do not find how to move the text up as normal... Even if I add padding...) :(
     
  5. Russ

    Russ Well-Known Member

    Did you remove the float:left on the user info container?

    Also the border, put a 0px border on the message container in the style properties.
     
  6. iGloo'

    iGloo' Member

    You are awesome Russ! http://prntscr.com/2yu3gs
    I deleted the float: left; :rolleyes:
    But i'm totaly lost, I can't find where to remove the border I want to delete. Can you like screenshot me exactly where to go or something? :unsure:
     
  7. Russ

    Russ Well-Known Member

    Probably set a 0 here.

    Screenshot_3.png
     
  8. iGloo'

    iGloo' Member

    Thank you for helping me, but I tried to modify what you told me, nothing change, there is the only thing I want to remove to have a perfect style (http://prntscr.com/2yuuy5). *-*
    I will search the answer, you helped me a lot. ;)

    Edit: I find that, but do not know where to add code... http://prntscr.com/2yvdc8
     
    Last edited: Mar 8, 2014
  9. Tracy Perry

    Tracy Perry Well-Known Member

    Instead of posting print screens to an image, a link would be easier to trouble shoot since not everyone has the same "style" that you do.
    You may want to try (in EXTRA.css)
    Code:
    .messageList .message {
    border: none;
    }
    
    Or in the ACP check the "Message List" in the image shown by Russ just above the segment he details... remove any borders there.
     
    Amaury likes this.
  10. iGloo'

    iGloo' Member

  11. Tracy Perry

    Tracy Perry Well-Known Member

    The blue border around all of it is controlled via the below css (as shown on your site)
    Code:
    .section {
    background-color: rgb(255, 255, 255);
    margin: 10px auto;
    border: 1px solid rgb(60, 179, 248);
    }
    Look in ACP -> Style Properties -> Building Blocks -> Section Main and see if you have a border defined there.
    The Text Box (or what I would refer to as the Text Box) already has a border around it... do you mean a border around each post (and the postbit) individually? If so, I'm not sure you can do that (or it's going to look like it did orginally)

    For the lines in between, you can control that in EXTRA.css with the
    Code:
    .messageList .message {
    border-bottom: 1px solid;
    }
    and modify the code to what you want (color and size).

    screenshot.png
     
    iGloo' likes this.
  12. iGloo'

    iGloo' Member

    Finally, I do not want a line between, it will look better.
    If I go to the Building Blocks properties as you said, it work, I tried it before, but by doing that, I lose my border around each block, like on the main page, forum statistics, etc... http://prntscr.com/2z5850
    I would like to be able to keep the border everywhere except when you're viewing a thread.

    I found the code that you wrote here, but I have no ideas how to put it with something like "border: none;", that's what I am looking for.
    I will search for this one too: http://prntscr.com/2z59nn because I wasn't able to remove it with the Building Blocks properties at all.
    Thank you for trying, I hope that someone would be able to answer me. :)
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    You may be able to use (in EXTRA.css)
    Code:
    .messageList .message  .section{
    border:none;
    }
    I'll have to set up a test style to play with to see if that works.

    Is this a custom style you have done or one from the Resources?
     
  14. iGloo'

    iGloo' Member

    I tried this code on EXTRA.css, the border is still here.
    This is a custom style I made from the Default style.

    Edit: I solved the quickreply area. The only thing I want to remove now is the "block" border on this section, when people are reading a thread. I will keep those borders everywhere else on my forum.
     
    Last edited: Mar 9, 2014
  15. iGloo'

    iGloo' Member

    Well, at now I modified the margin/padding to make it fit and look more clean, but it's not what I really want, some parts of the border are still visible.

    Whem I examine the page, I found it as said before:
    Code:
    .section {
    background-color: rgb(255, 255, 255);
    margin: 10px auto;
    border: 1px solid rgb(60, 179, 248);
    }
    When I remove the border it make th page as I want to be, so the question is: How to put the code to only remove the border when people are reading messages and not on the all forum, also, what would be the code?
    I tried some differents ways, like:
    Code:
    .messageList .message  .section{
    border:none;
    }
    but still impossible to remove it, HELP. :(
    Thank you in advance if you have the magic answer.
     
  16. Tracy Perry

    Tracy Perry Well-Known Member

    I'll have to look at it later. Heading out to a TitanFall pre-release party right now. Going to have some fun playing games then head to pick up the game at midnight and come back and play it.
    Is this based off the default style? If so, I'll hit you in conversation and give you an email to send the export of it to and I can play with it some.
     
  17. iGloo'

    iGloo' Member

    Yeah it's based of the default style. I'll wait to receive the answer by conversation. Again, thank you Tracy Perry for trying to help me and all the other people who helped me before.
    :)

    EDIT: I found how to fix it. I only had to add the
    Code:
    .section
    {
    border: none;
    }
    on my template message.css
    I know I did it before, but I was adding this code at the end of the template, I tried to add it at the beginning, and it seems that's it's working.
    :D
     
    Last edited: Mar 12, 2014

Share This Page