1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Member posts history

Discussion in 'XenForo Questions and Support' started by LuvMeSumZen, Jan 30, 2014.

  1. LuvMeSumZen

    LuvMeSumZen Active Member

    I have noticed that not all posts are visible in the "Postings" tab for members that haven't posted in a long while. There is not even a "Find all content..." option availble for some members. Their post count can show as xx but not posts are visible. I want all my members entire history to be kept in the DB and available to everyone. Is this not an option in XF?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. LuvMeSumZen

    LuvMeSumZen Active Member

    I tried using Search on a member that is showing 7 posts, but only his most recent 6 come up. It is not limited to just him either.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try rebuilding the search index.
     
  5. LuvMeSumZen

    LuvMeSumZen Active Member

    By using the Rebuild Caches tool in ACP?
     
  6. LuvMeSumZen

    LuvMeSumZen Active Member

    I got some errors. Should I be concerned about any of these?

    rebuild.jpg
     
  7. Mike

    Mike XenForo Developer Staff Member

    I don't actually see how that error is possible -- the query is written in such a way that it should never happen...
     
  8. LuvMeSumZen

    LuvMeSumZen Active Member

    Yet, there it is. It's Greek to me but it was certainly generated by me simply running the Rebuild Index.
     
  9. Mike

    Mike XenForo Developer Staff Member

    Does it happen if you try again?
     
  10. LuvMeSumZen

    LuvMeSumZen Active Member

    I don't know let me do so . . . .
     
  11. LuvMeSumZen

    LuvMeSumZen Active Member

    I tried to rebuild all cahces first by using the Rebuild Caches on the sidebar and got a long list of errors all of which could not even be seen - and it would not even attempt to rebuild anything . . . . . .

    rebuild1.jpg


    So I "X"d it out and used the Rebuild Index alone and got this again . . .

    rebuild2.jpg


    What does this mean?
     
  12. Mike

    Mike XenForo Developer Staff Member

    I really don't understand how that's actually possible with that query. Can you submit a ticket with admin CP and FTP details so I can debug it?
     
  13. LuvMeSumZen

    LuvMeSumZen Active Member

    Mike, my internet has been down since Saturday and I just saw this. I was attempting to upload a add on and got this same error message again and remembered this thread. I have never submitted a ticket here but am sure I can figure it out, will do so as soon as I do . . . .
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page