1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Massive decrease indexed pages google

Discussion in 'Off Topic' started by Robby, Jun 27, 2015.

  1. Robby

    Robby Well-Known Member

    In webmaster tools i see that my forum has an enormous decrease in indexed pages by google. From nearly 6000 urls to 600 now. I really don't know why it is and haven't change anything i know off.
    Are there people with the same headache?
    My forum has a third of visitors in a couple of weeks.
    This is my robots.txt:
    Code:
    User-agent: *
    User-agent: Mediapartners-Google
    Disallow: /find-new/
    Disallow: /account/
    Disallow: /attachments/
    Disallow: /goto/
    Disallow: /posts/
    Disallow: /login/
    Disallow: /admin.php
    Allow: /
    
    Sitemap: http://www.site.com/CODE]
    Anything wrong with that?
     
    Last edited: Jun 27, 2015
  2. Fred.

    Fred. Well-Known Member

    Aiaiai, Penalty from google?

    Do you see anything in Search Traffic --> Manual Actions in webmaster tools?
     
  3. Robby

    Robby Well-Known Member

    That was my first guess, but i see nothing in webmaster tools...
     
  4. Fred.

    Fred. Well-Known Member

    Do you have redirects in place from other software you used before? Are they still working?
     
  5. Robby

    Robby Well-Known Member

    Nope, i only changed the format in webmaster tools because google asked.
     
  6. imthebest

    imthebest Formerly Super120

    What do you mean when you say "I only changed the format because Google asked". Could you please elaborate on this?
     
  7. Robby

    Robby Well-Known Member

    Hi,

    I dont know the right name for it but i got in webmaster tools the question to choose between www.site.com en site .com
    I have chosen site.com

    But @Andy figured out that i have more then 11000 pages indexed, but in webmaster tools it says 600.
    Could webmaster tools be wrong. There is a decrease in visitors so it's all very strange.
     
  8. Robby

    Robby Well-Known Member

    Should it help if i removed my robots.txt?
    I dont think it's very different from this on xenforo.com but you never know.
    There is something that must be wrong.
     
  9. Martok

    Martok Well-Known Member

    You should have added whichever version your site resolves to, so if your site uses www then you use that, if it doesn't then you don't. Note that your site shouldn't be available at both.

    You shouldn't remove the robots.txt file, that's not causing the issue.
     
  10. Robby

    Robby Well-Known Member

    The site automatic redirects to site.com. The www.site.com sends it automaticly to site.com.
    Is this not good?
     
  11. Martok

    Martok Well-Known Member

    That's fine, I was just checking that you'd set things up correctly.

    I notice that you have www.site.com in your robots.txt for your sitemap.
     
  12. Robby

    Robby Well-Known Member

    Thanks for noticing. My fault.
    I'm gonna change that. (y)
     
  13. Robby

    Robby Well-Known Member

    This is what i don't get:
    5313 pages send ---> 630 indexed and decreasing?

    sitemap.png
     
  14. Fred.

    Fred. Well-Known Member

    Because you are still checking the www version? Make sure you add the right domain in WMT. domain.com in this case. Without the www
     
  15. Robby

    Robby Well-Known Member

    No that was changed.
     
  16. Fred.

    Fred. Well-Known Member

    And the right urls are in your sitemap? Or maybe they where wrong before?
    Then you need to wait until it is re-indexed.

    If you want you can pm me the url so I can have a quick look to see if there is still something wrong.
     
  17. Robby

    Robby Well-Known Member

    I have just checked the basis board information in the acp and there was still the old url www.site.com
    I guess this could be the problem because the sitemap takes that info. Not?
     
    Fred. likes this.
  18. Fred.

    Fred. Well-Known Member

    That's what I just PM'ed you. :D (y)
    You are right.
     
    Robby likes this.
  19. Deathstarr

    Deathstarr Active Member

    After you change to non-www make sue to rebuild your sitemap also.
     

Share This Page