• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Mass email failing

mmoore5553

Well-known member
#1
I have around 4000 user and was going to test sending mail out and get this error around the 2000 mark. Any ideas how to fix this ?

Fatal error: Zend_Mail_Transport_Sendmail::_sendMail() [function.require]: Failed opening required 'Zend/Mail/Transport/Exception.php' (include_path='/home/barefoot/public_html/library:.:.:/usr/lib/php:/usr/local/lib/php') in /home/barefoot/public_html/library/Zend/Mail/Transport/Sendmail.php on line 139
 

Digital Doctor

Well-known member
#6
I have around 4000 user and was going to test sending mail out and get this error around the 2000 mark. Any ideas how to fix this ?
Seems like people have to make this mistake before they know of the limitation.
Where (I assume in the adminCP) would a warning be needed to be placed for you to not make this mistake ?
 

Brogan

XenForo moderator
Staff member
#8
Ouch maybe that is why we got blocked last time. Is there a way to span it out into intervals ?
Try this.
Email throttling has been suggested so I have merged the threads.

In the meantime you can try doing this.

The email send function sends 100 emails per page and automatically submits the next page.
You can delay that submission for x minutes, which will have the same effect as throttling to a specified number of emails per hour.

Edit the user_email_send admin template and replace the script block at the end with:

Code:
<script>
$('#emailButton').hide();
 
window.setTimeout(function() {
  $('#emailForm').submit();
  $('#emailButton').hide();
  $('#loadingImage').show();
}, 32 * 60 * 1000);
</script>
The 32 in the code above is the number of minutes to delay the next page submission.

A maximum of 59 minutes may be the limit as setTimeout might not like anything over an hour.

This only limits the email send function from within the ACP.
Any other emails related to threads, conversations, etc. will also need to be factored in.
 
#11
I can't seem to see user_email_send admin in the list there. Could it be that it was not installed? Or do I need to login as the God account in order to see it? My normal user account is not the God account, but a separate user account designated as a superadmin.
 

Jake Bunce

XenForo moderator
Staff member
#12
I can't seem to see user_email_send admin in the list there. Could it be that it was not installed? Or do I need to login as the God account in order to see it? My normal user account is not the God account, but a separate user account designated as a superadmin.
It is located here:

Screen shot 2012-03-16 at 6.22.35 PM.png

If you don't see it then try with your super admin.
 

Jake Bunce

XenForo moderator
Staff member
#14
Would you also mind showing me where the user_email_send template is in that page?
Admin CP -> Development -> Admin Templates -> user_email_send

The Development tab only shows in debug mode. To enable debug mode you need to add this line to your library/config.php file:

Code:
$config['debug'] = 1;
 

andybond

Active member
#15
At the risk of resurrecting an old thread - this template doesn't appear to be in v1.5

Is this correct ?

if so how do I go about limiting in XF?