1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Lots of Problems

Discussion in 'Troubleshooting and Problems' started by Eric J., Feb 9, 2012.

  1. Eric J.

    Eric J. Well-Known Member

    I had a MyBB board originally, but have had a XenForo license since the first day it went on sale. I only recently tried to go through the horrible migration (It was for me anyways), from MyBB, to IPB, and finally to XenForo. Among other problems (No passwords working, avatars all gone, etc), I can't install some plugins or themes.

    The plugin I can't install is XFArcade, which is reportedly supposed to work on 1.1.2. (Well, I can install it, but it doesn't work at all)

    I haven't been able to install any themes at all up to this point, heck, I can't even change my images without them breaking (The logo image specifically) unless I link to it offsite.

    You can see some of the problems I'm having here:

    http://xenforo.com/community/threads/aurora.26977/#post-324342

    and here:

    http://xenforo.com/community/threads/flexile.7164/page-55#post-324118

    There are more than that, but I got tired of posting in threads because they're all happening.

    I love Xenforo and hope to get this seemingly huge problem worked out. (Yes I set data and internaldata to 777)

    Edit: Oh and this doesn't look right either.

    http://xenforo.com/community/threads/sitemap-for-xenforo.26785/#post-324154

    Here are my plugins:
    Custom BBCode Manager v1.2.1
    Online Status 1.1
    ragtek FrameWork 1.1.7
    ragtek Latest Posts Sidebar Block 1.1
    XF Arcade 0.0.7
    [8wayRun.Com] XenUtiles (Tools) 1.1.5
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have a link to your site?
     
  3. Eric J.

    Eric J. Well-Known Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

    At first glance I don't see any problems.

    Everything seems to be working fine.
     
  5. Eric J.

    Eric J. Well-Known Member

    That's the problem I seem to be having. It works perfect as is, but trying to add themes is completely breaking it. And some plugins I add don't work at all (Ones reported to work on 1.1.2 while following all the instructions).
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    What errors do you receive when installing styles or add-ons?

    Which FTP program are you using?

    Do you get any ACP or server errors?
     
  7. Eric J.

    Eric J. Well-Known Member

    Well, the plugins just don't take effect at all (When they don't work). Like, http://pokebattlecenter.net/arcade/ should work, afaik, but isn't.

    As for themes, in the links above you can see, they just completely break (Aurora even breaks my default theme), though other people with 1.1.2 are reporting it working fine.

    Using Filezilla FTP program.

    No errors whatsoever from the ACP.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Without evidence of the problem related to a style, it's difficult to say what the problem is.

    You need to try installing a style compatible with the version of XenForo you are running and then I can check to see what the issues are.

    I can't comment on the arcade add-on as I don't have it and I have no access anyway.
     
  9. Eric J.

    Eric J. Well-Known Member

  10. Brogan

    Brogan XenForo Moderator Staff Member

    I can see the issues with the Aurora style, but I don't see any problems with the default style, so you can safely leave it installed.

    I'll have a look to see if anything stands out but initially there is a weird corrupted graphic effect on the nav bar.
    That comes from this image though: http://pokebattlecenter.net/styles/aurora/xenforo/main_menu_bg.gif
    So that is correct, if that is how the image is supposed to look.
    Otherwise it is being corrupted during the FTP process.

    One thing is obvious, there are no icons on the forum home page, so you either haven't uploaded them or you haven't configured something correctly.

    The category gradient for example: http://pokebattlecenter.net/styles/aurora/xenforo/gradients/gradient1.png

    I suspect it's the former, as most of the images appear to be missing.
     
  11. Eric J.

    Eric J. Well-Known Member

    I'm looking at the default theme right now, and it looks a lot like Aurora, are you sure that you aren't looking at the default theme? I mean I can screen it, I know it can't just be me.

    As for the images problem, this has only happened to me with Xenforo. For example:

    http://pokebattlecenter.net/styles/default/xenforo/logo.png

    I know for a fact this image is in that exact place, but it just won't work. :(
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    I suspect you're seeing issues related to browser caching - the default style appears fine.

    That image isn't valid and won't open in an image editor

    It doesn't really make sense that some images work and some don't.
    This for example is fine: http://pokebattlecenter.net/styles/default/xenforo/overlay/close.png

    I suspect you are experiencing some sort of corruption during the FTP process.
     
  13. Eric J.

    Eric J. Well-Known Member

    Hm.. I've tried Shift + Refresh and it still appears the same to me, yet one of my users also sees the default theme fine. :/

    And hm... would having my FTP program set to ASCII instead of Auto or Binary give me problems? And also, because of the speed difference, when uploading Xenforo I used GoFTP, but uploading themes and plugins I use FileZilla. Could that possibly cause problems? Also, other than the two data folders should anything be set to 777 permissions?
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Your FTP program should be set to Auto.

    I suspect that is the cause of your problems.
     
    Eric J. likes this.
  15. Eric J.

    Eric J. Well-Known Member

    Who knew that such a simple option in FileZilla would have such an impact, the software should really have a warning when you change that setting, or put it in advanced. xP

    But yeah, the theme works now. Flexile still doesn't but I'm assuming that's because it isn't updated for 1.1.2.

    I'm still having the issue where my other themes are corrupted by Aurora, though, no idea why. I've cleared my cache, didn't help. :/

    Thanks for the awesome help Brogan. :D
     
  16. Morgain

    Morgain Well-Known Member

    Eric I had lots of problems with graphics too. XF seems to be very sensitive about them!
    Pace Brogan who says Auto is best, I found that I needed to be very careful to always always upload graphics in binary, not rely on auto.
    Also whatever I downloaded from elsewhere, never to Copy the file or SCR, always use rightclick/ Save As.
     

Share This Page