1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Lots of errors after upgrade and impossibility installing mods

Discussion in 'Troubleshooting and Problems' started by mono, Dec 3, 2013.

  1. mono

    mono Active Member

    Hello. Recently I've done an upgrade from 1.1.4 to 1.2.3 and everytihing seemed fine until I started installing some mods. Doing that I've found that they couldn't be install and also found these errors:
    Code:
    ErrorException: Argument 1 passed to Tinhte_XenTag_XenForo_DataWriter_Discussion_Thread::_discussionPostSave() must be an array, none given, called in /library/XenForo/DataWriter/Discussion.php on line 453 and defined -library/Tinhte/XenTag/XenForo/DataWriter/Discussion/Thread.php:83
    
    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\'0\', `advert_name` text CHARACTER SET latin1 NOT NULL, `advert_code` l' at line 3 - library/Zend/Db/Statement/Mysqli.php:77
    
    ErrorException: Argument 2 passed to XenForo_Model_Post::alertQuotedMembers() must be an array, none given, called in /library/DoublePost/ControllerPublic/Thread.php on line 224 and defined - library/XenForo/Model/Post.php:1582
    
    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Table 'table_xf.liamadsplus_adverts' doesn't exist - library/Zend/Db/Statement/Mysqli.php:77
    
    XenForo_Exception: Invalid model 'LiamAdsPlus_Model_Adverts' specified - library/XenForo/Model.php:192
    
    ErrorException: gzopen(sitemap/sitemap.threads.pags.1.xml.gz): failed to open stream: Permission denied - library/XfAddOns/Sitemap/Sitemap/Base.php:93
    I'm pretty shure it isn't cause by mods itself and there is something different. I will appreciate for your help.
     
  2. MattW

    MattW Well-Known Member

    Have you updated all the add-ons to the most recent versions to make sure they work correctly on XF 1.2?
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    All of those errors listed are caused by add-ons:
    Tinhte_XenTag
    DoublePost
    liamadsplus_adverts
    XfAddOns/Sitemap

    Did you follow the instructions in the "How to upgrade to 1.2" resource?
     
  4. mono

    mono Active Member

    Thank you, it is. This is my fault. I've made all the necessary updates. Seems that errors has gone exept this one, when I tried to install xencentral adserver:
    Code:
    ErrorException: Fatal Error: Class 'XenCentral_Framework_Install' not found - library/XenCentral/AdServer/Install.php:13
    
    So I still have an issue with installing mods, at least this one.
     
  5. MattW

    MattW Well-Known Member

    You'll need to report it to the add-on author to have them assist in fault finding it, as it's saying the install class is missing. Could be a simple as a file not correctly uploaded.
     
  6. mono

    mono Active Member

    Seems that file on its place. Ok, thank you, I'll contact developer.
     

Share This Page