• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lost connection to MYSQL server ERROR and site down!

#1
I'm really really hoping that someone can help me with this.
For the last couple of hours my site has been down and the error logs show the below error.
The last thing I did was install and run Add Ons :
- Description for RSS 1.2 and
- Sitemap for XenForo 1.2.0

I understand that running the sitemap probably slowed the site down but the cron job has finished running and the site is still down. I can access Admin but not the forum. It just shows a blank screen.
I would very much appreciate if someone could lead me in the right direction.

Zend_Db_Adapter_Mysqli_Exception: Lost connection to MySQL server at 'sending authentication information', system error: 32 - library/Zend/Db/Adapter/Mysqli.php:333
Generated By: Unknown Account, 32 minutes ago
Stack Trace
#0 /home2/stockfo5/public_html/SharesGuru/library/Zend/Db/Adapter/Abstract.php(315): Zend_Db_Adapter_Mysqli->_connect()
#1 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Application.php(553): Zend_Db_Adapter_Abstract->getConnection()
#2 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Application.php(780): XenForo_Application->loadDb(Object(Zend_Config))
#3 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Application.php(810): XenForo_Application->lazyLoad(Array, Array)
#4 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Application.php(1098): XenForo_Application::get('db', NULL)
#5 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Model.php(161): XenForo_Application::getDb('db')
#6 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Model/DataRegistry.php(138): XenForo_Model->_getDb()
#7 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Model/DataRegistry.php(97): XenForo_Model_DataRegistry->_getMultiFromDb()
#8 /home2/stockfo5/public_html/SharesGuru/library/XenForo/Dependencies/Abstract.php(134): XenForo_Model_DataRegistry->getMulti(Array)
#9 /home2/stockfo5/public_html/SharesGuru/library/XenForo/FrontController.php(125): XenForo_Dependencies_Abstract->preLoadData(Array)
#10 /home2/stockfo5/public_html/SharesGuru/admin.php(13): XenForo_FrontController->run()
#11 {main}
Request State
array(3) {
["url"] => string(38) "http://www.sharesguru.com.au/admin.php"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 
#2
Update: Finally solved it.
In case anyone happens to come across the same problem, my issue had nothing to do with the database.
*Somehow* there was an empty index file in the forum root. I have no idea how it got there, or why it was empty but once it was replaced, everything worked again.

I'm still puzzled at how the problem occurred. Would be good to know to prevent it in the future.
I can't rule out human error - I'm still new to Xenforo so probably bungled something up without realizing it.
 

Jake Bunce

XenForo moderator
Staff member
#3
An empty index file should have nothing to do with this error.

This exact error was recently reported to me via PM. My replies to that PM:

Jake Bunce said:
That error is generally caused by one of these MySQL settings being exceeded:

wait_timeout
max_allowed_packet

Your host or server person needs to increase these settings in MySQL. There is more info here:

http://dev.mysql.com/doc/refman/5.1/en/gone-away.html
Jake Bunce said:
Yes, an auth problem with the MySQL server, per the error message.

https://www.google.com/search?q=los...g+authentication+information'+system+error+32

There are several different takes on this error. This guy identified the problem as old password hashes for MySQL users:

http://www.coolcomputing.com/article.php?sid=4487

In that situation you should be able to generate new hashes by just deleting and recreating your MySQL user through whatever hosting control panel your host has provided. Or you can get into the MySQL user records if you have the root MySQL login.


That's just a possible explanation. The above Google search has some others.
Jake Bunce said:
I don't know. It's a possible solution to this server problem. I am just pulling from Google. I have not encountered this particular error before (the auth error with sys error 32).
He said recreating the MySQL user appears to have fixed the error.
 
#4
Thanks for the info Jake. I had searched google for hours with no luck.
Very odd though. In the end I had finally contacted my hosting provider. They had said there was nothing wrong with mysql. And when I asked what they had done to get it back online, told me they had replaced the index file in the root directory. Didn't make sense to me but assumed they knew more than I did.

I'll check the above MySql settings. This isn't a problem I want happening again.