1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Logo not appearing in Facebook Integration

Discussion in 'Troubleshooting and Problems' started by OverHere, Jan 18, 2014.

  1. OverHere

    OverHere Active Member

    Please see the attached images - these come up when some one is signing up via Facebook and after this process that new member is brought back to the site logged in. My developer is unable to get my logo to appear in the 2 empty left side boxes in the 2 attached photos.

    But, when I go through the FB sign up process as a new member on the XenForo forum, I do see the XenForo logo in the 2 FB equivalent boxes here.

    Please advise how to get our logo to appear in the 2 boxes in the attached photos:

    2fb.jpg

    1fb.jpg
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Add it to your app in the settings.
     
  3. OverHere

    OverHere Active Member

    Thank you - 1) What size should this logo be? (100 x 100?)

    2) - Also, please advise how to get our logo into the separate FB 'Recommend' bit - like you have it for this website in the attached photo...

    - Also, what size should be the logo in the 'Recommend' bit? (200 x 200?)

    recommend.jpg
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    See the FAQ in my signature for how to change the logo which is displayed on FB pages.

    Use 200x200px.
     
    OverHere likes this.
  5. OverHere

    OverHere Active Member

    My developer is saying "Regarding the images fb1 and fb2, there’s no option for me to change these icons in the instructions that are provided by XenForo in their manual" - can you please dive a precise link where the relevant instructions can be found.
     
  6. OverHere

    OverHere Active Member

    In relation to my first message in ths thread and the 2 photos therein, do you mean the logo integration direction is the bit 'Changing the Default Open Graph Image' at http://xenforo.com/help/facebook/?
     
  7. SchmitzIT

    SchmitzIT Well-Known Member

    Hi Paul,

    Where is this done? I tried looking for it, but do not see any fields where to add it. It's definitely not something covered in the Facebook part of the manual.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I set my app up several years ago.
    As I understand it, Facebook have radically changed the page now so I don't know where it is (I haven't logged in to my app for years) - it used to be under the edit tab.
     
  9. Mike

    Mike XenForo Developer Staff Member

    I think it's under "App Details", though there are about 6 different images there with specific sizes expected (very annoying)...
     
  10. SchmitzIT

    SchmitzIT Well-Known Member

    I just came across those. It's odd, because the other day I was trying to figure out where to place an image or icon, and while the settings seem similar, the screens are radically different today. The other day it also had a firm message about the app requiring official approval of some kind in case of changing things in that screen.

    Is Facebook randomly showing different screens just to mess with devs or something?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Facebook constantly updates and changes stuff.
    It's a challenge keeping code and documentation up to date.
     
  12. Mike

    Mike XenForo Developer Staff Member

    It's quite possible that the screens have legitimately changed, as they roll changes out slowly in some cases. Alternatively, it's possible they're A/B testing changes.
     
  13. SchmitzIT

    SchmitzIT Well-Known Member

    I know. The comment was more tongue-in-cheek :)
     

Share This Page