1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Login with Twitter: "An unexpected error occurred. Please try again later."

Discussion in 'Troubleshooting and Problems' started by MikeMpls, Apr 18, 2014.

  1. MikeMpls

    MikeMpls Well-Known Member

    Getting this error when I try to login with Twitter: "An unexpected error occurred. Please try again later."

    Something reportedly was causing this on 1.3.0 that is fixed on 1.3.1.

    Well, I'm trying this with 1.3.1. :)
     
  2. MikeMpls

    MikeMpls Well-Known Member

    Found the "Test Twitter Integration" option on the tools page, this was its feedback:

    "Twitter returned the following error: Could not retrieve a valid Token response from Token URL: Failed to validate oauth signature and token."​
     
  3. optrex

    optrex Active Member

    I'm getting the same
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. optrex

    optrex Active Member

  6. MikeMpls

    MikeMpls Well-Known Member

    Yes, still doesn't work. I had followed the instructions in the guide in the Resources section, which are equivalent, although the page you linked is a better presentation.

    So I went back into Twitter, deleted the application, and started over following your instructions. And it still doesn't work.

    This is on a site that was a clean install of 1.3.1 (not an upgrade) earlier in the week, only mod is Xenique's DXF Blue style, no add-ons. It passes the File Health Check.

    The response from the "Test Twitter Integration" option on the site's Admin/Tools page is:

    I tried it on a different site that I upgraded to 1.3.1 from 1.2.x a few days ago, also with DXF Blue. Twitter integration works just fine on that site.

    Have to upgrade another site yet tonight, will see if Twitter wants to work on that one. :)
     
  7. Mike

    Mike XenForo Developer Staff Member

    The first reference I see on Google relates to the server clock being wrong. I'd check that. Is the site that works on the same server?

    In general, the process to create the signature is handled by a library so I would expect it to be wrong for significantly more people if it was a bad calculation there.
     
  8. MikeMpls

    MikeMpls Well-Known Member

    Twitter registration works just fine on the site that I upgraded (1.1.3 --> 1.3.1) last night. That's the only one w/ real content & users.

    All three sites are on the same server (VPS @ KnownHost).

    The server time is correct. I ran across those posts early early on.

    It works on the two upgraded sites, not on the fresh install. When's 1.3.2 coming out? :)
     
  9. Mike

    Mike XenForo Developer Staff Member

    If you want me to look into this to see if I can figure out what's going on, submit a ticket with ACP and FTP access details please.
     
  10. MikeMpls

    MikeMpls Well-Known Member

    Will get that submitted as soon as I can. The site where it didn't work is just a concept to play with for a while. I tried the Twitter affiliation out there hoping to get it down before I upgraded that other site over the weekend.
     
  11. MikeMpls

    MikeMpls Well-Known Member

    Occurs to me that I should run thru all of this site's directories & files and change the owners to the account the site actually runs under.

    I do my installations with root access, then chown the "data" & "internal data" directories to humor your installation.

    A problem like this could be a subtle side effect of a directory or file owned by the root.
     
  12. MikeMpls

    MikeMpls Well-Known Member

    It works now that I upgraded the newly-installed 1.3.1 site to 1.3.2.

    So, either there's a subtle difference between 1.3.1 upgrades vs. full installation, or you fixed it in 1.3.2.
     
  13. abbychase

    abbychase Active Member

    Did you find a fix?
     

Share This Page