• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Login Form Broken

Tracy Perry

Well-known member
#4
mcsg.in, change your style at the style picker to "Flexile Dark - Green Dave's Test" or something around them lines
You have
Code:
.xenForm .ctrlUnit dt {
width: 17px;
}
defined so it limits it to 17px. Fix that and it should work.

I think that (in EXTRA.css)
Code:
#loginBar .xenForm .ctrlUnit dt {
width:  200px;
}
"should" work with the default definitions - you may have to add an !important after the 200px... but you need to find where that 17px is being set at and comment it out.
 

Tracy Perry

Well-known member
#9
Same basic problem... somewhere in your style you you have
Code:
.xenForm .ctrlUnit dt {
width: 17px;
}
set. You need to find that and adjust it.
If you can't find it, try doing a (in EXTRA.css)
Code:
.xenForm .ctrlUnit dt {
width: 32%;
}
and you may need to add an !important after the 32%. If you do this, comment out the above code as it will work for it also.

edit:
Actually, it's going to take more work than that. Is this based off the Flexile theme that is not 1.2 compatible (responsive)?

Code:
.xenForm .ctrlUnit dt label {
margin-left: none;
}
.xenForm .ctrlUnit dt {
width: 32%;
}
may work, but the date of birth still uses the UL definition for display:block and I think it needs to be display:inline.

Second edit:

For the birthday try:
Code:
#helper_birthday {
display: inline-block;
}
in EXTRA.css.
 
Last edited:

Tracy Perry

Well-known member
#10
I'm not going to fool with installing Flexile on my setup to try it out. It would be much easier if I had access to your system to try these changes out. If you want to do that just start a conversation with me with a username/password and have it set up as an Administrator and I'll log in and see if I can trouble shoot it for you.
 
#12
We fixed the login form for the most part. The forum has been on 1.2 for a while now, but we are attempting to get our old theme back so we are able to essentially re-launch the forum.

Also the quick reply box expands when you type in it. So to begin with it will look like so:

But as you type in it it begins to expand a line for every letter


PS: I know how to fix the BB code.
 
Last edited:

Tracy Perry

Well-known member
#13
We fixed the login form for the most part. The forum has been on 1.2 for a while now, but we are attempting to get our old theme back so we are able to essentially re-launch the forum.

Also the quick reply box expands when you type in it. So to begin with it will look like so:

But as you type in it it begins to expand a line for every letter


PS: I know how to fix the BB code.
First problem I see is you are using the 1.1 editor sprite sheet. You need to update it to the 1.2 version. Question.... did you read @Brogan's resource on what needs to be done to update to 1.2?
Second... if this "style" is based off of the 1.1 Flexile Dark then there are going to be LOTS of problems with it. General consensus is that it's "dead" in the water as far as updates goes and it flat out won't work with 1.2 without some heavy duty modifying. You may have better luck using the light Flexile and customizing it.