• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Links in e-mail does not look right

fredrikse

Active member
#1
Hi,

Does anyone know what's upp with the strange looking phrases and links in the e-mail you get when someone sends you a private message?

email.jpg
 

Jake Bunce

XenForo moderator
Staff member
#2
That is a problem with your language pack. To fix the problem you need to find that phrase and revert it:

Admin CP -> Appearance -> Search Phrases

Search for a part of the email such as "{username} started".
 

fredrikse

Active member
#3
Thanks for the pointer!

What's the big difference between conversation_insert_messagetext_email_text and conversation_insert_email_text? To me they look pretty much the same.
 

Jake Bunce

XenForo moderator
Staff member
#5
I have tried to change both of these phrases. I still get english in the mails sent out when a new conversation is created.
That is expected. When you revert the phrase it will be restored to the default which is English. But it should fix the problem of unparsed tokens like {username}.
 

fredrikse

Active member
#6
That is expected. When you revert the phrase it will be restored to the default which is English. But it should fix the problem of unparsed tokens like {username}.
Moste of the phrase errors in e-mail templates has been resolved by reverting them and then reapplying the swedish phrases again. I have done some testing to force the emails to be sent out. It looks pretty good. Still one phrase refuse to "get in line" after reverting it and reapplying the correct phrase once again.

The phrase watched_thread_email_html_footer_1 looks like this:
"Det här meddelandet skickades till dig eftersom att du valde att bevaka tråden {title}{board_title} med e-postupplysningar om nya svar."

The phrase title and board title doesn't translate. In other phrases the translate correctly.

What should I try?
 

Jake Bunce

XenForo moderator
Staff member
#7
Moste of the phrase errors in e-mail templates has been resolved by reverting them and then reapplying the swedish phrases again. I have done some testing to force the emails to be sent out. It looks pretty good. Still one phrase refuse to "get in line" after reverting it and reapplying the correct phrase once again.

The phrase watched_thread_email_html_footer_1 looks like this:
"Det här meddelandet skickades till dig eftersom att du valde att bevaka tråden {title}{board_title} med e-postupplysningar om nya svar."

The phrase title and board title doesn't translate. In other phrases the translate correctly.

What should I try?
Those tokens are wrong. On my 1.1.3 forum the phrase is:

Code:
This message was sent to you because you opted to watch the thread {thread} at {board} with email notification of new replies.
It uses {thread} and {board}.
 

fredrikse

Active member
#8
My mistake. Now when I reverted the actual phrase once again you are right about the phrases. It uses {thread} and {board}. I can see that now. Something must have gotten messed up earlier when I cut and pasted between phrases. Thanks again.