• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Link Check

Link Check 1.7

No permission to download
Verifies links in posts are valid and reports any which return HTTP status code 404.

AndyB

Well-known member
#1
AndyB submitted a new resource:

Link Check - Verifies links in posts are valid and report any which return error code 404.

Description:

The Link Check add-on will verify links in posts are valid and report any which return error code 404.

(Example of results page)

View attachment 64178

(Example of Options page)

View attachment 64179

URL switches:

Limit: This required switch will determine how many posts will be checked. Note that only posts with the URL tags will be selected. So if you set the limit switch to 50, the first 50 posts with links will be verified....
Read more about this resource...
 

Alfa1

Well-known member
#4
Likely this will expose thousands of dead links. Please add a function to have dead link reports show up in the report center, so that the appropriate moderator can take care of it.
 

Breixo

Active member
#9
Thanks @AndyB!
I started to use it. The problem is that I have a forum with 548k messages and lots of broken links, a huge task to check all threads and "unlink" (removes the link but leaves the link text intact) manually:

1º Detect broken link
2º Add a option to unlink:
2.1 Using something like "Post content replacement tool", look for http://example.com and delete everything OR leave just "example.com"
2.2 That combined with a mass select feature like "user moderation - mass select", so it would be easier to select several broken links simultaneously.

Is it possible to add this feature?

That would make yours a really useful addon!
Thanks for sharing your work :)
 
Last edited:

Rob

Well-known member
#10
As it stands it is depressingly awkward to use and lacks three things that are important.

1. I'd like to see a 'next x' link where x = limit.

2. The mod currently works backwards, starting at the most recent content. It would be useful to have a switch to work forward so we can start at post 1 - Think this is needed because it is older content that is far more likely to have missing links.

3. Please detect and trap bad urls to prevent errors like this:-
Server Error
curl_init() [function.curl-init]: Invalid URL 'http://javascript:AL_get(this, 'jour', 'Pract Mais.');'

  1. XenForo_Application::handlePhpError()
  2. curl_init() in Andy/LinkCheck/ControllerPublic/LinkCheck.php at line 162
  3. Andy_LinkCheck_ControllerPublic_LinkCheck->actionIndex() in XenForo/FrontController.php at line 347
  4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  5. XenForo_FrontController->run() in /var/www/vhosts/eatmyshorts/httpdocs/index.php at line 13
 
Last edited:

Ferdinand

Active member
#12
I get the following error, when it's set to 404 only. The page loads if I use all errors.:
An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/carpedie/public_html/library/Zend/Db/Statement/Mysqli.php on line 77

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 734
  5. Zend_Db_Adapter_Abstract->fetchAll() in NodesAsTabs/Model/Options.php at line 43
  6. NodesAsTabs_Model_Options->getJoinedOptionsForNav() in NodesAsTabs/NavTabs.php at line 25
  7. NodesAsTabs_NavTabs::createNodeTabs()
  8. call_user_func_array() in XenForo/CodeEvent.php at line 90
  9. XenForo_CodeEvent::fire() in XenForo/Dependencies/Public.php at line 493
  10. XenForo_Dependencies_Public->_getNavigationContainerParams() in XenForo/Dependencies/Public.php at line 373
  11. XenForo_Dependencies_Public->getEffectiveContainerParams() in XenForo/FrontController.php at line 612
  12. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  13. XenForo_FrontController->run() in /home/carpedie/public_html/index.php at line 13
 

AndyB

Well-known member
#15
I suggest you install the add-on again. Sometimes files are not copied correctly for whatever reason and this is the error you get when that happens.
 
#19
Thanks for this addon!

It would be great if you would add a link to the link checker somewhere (For example into the account popup). Or did I just miss a link?