1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Limit # in inbox dropdown

Discussion in 'Troubleshooting and Problems' started by Hiiragi, Apr 18, 2011.

  1. Hiiragi

    Hiiragi Member

    I figure this would be the easiest way to remedy what my problem is. After doing a test import from IPB 3.1.2 I found that I had a huge moderation queue (4.5k) and a huge amount of unread conversations (4.3k). I can pretty much remedy the moderation queue by taking care of it before I fully convert but inboxes are another issue. From what I'm noticing, even after running the query I found to mark all as read, all 4.3k conversations still load into the inbox dropdown. Therefore, unless there is a way to remove them all since, as far as I know, they should only be recent conversations, I would have to either limit the # shown or try and disable the dropdown until they no longer count as recent.

    Any input would be greatly appreciated!
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You are referring to these queries right?


    The cutoff for the inbox menu is 3 hours by default. You can change it:

    Admin CP -> Home -> Options -> User Alerts -> Hours to Retain Viewed Alerts in Popup
    Hiiragi likes this.
  3. Hiiragi

    Hiiragi Member

    Indeed I am. However, I just checked that option under options and it seems like the option below for read messages is what I'm looking for. I think I will have to wait a bit to see if it removes them.

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yeah that's possible.

    FWIW, I just tested those queries again on my own import and I didn't have any problems. My Inbox menu is empty. I got those queries from the XenForo code (XenForo_Model_Conversation::markConversationAsRead) so I know they are correct. I do arbitrarily set last_read_date = UNIX_TIMESTAMP() in that one query, but I am pretty sure that is OK. There have been no problems in my testing.
  5. Hiiragi

    Hiiragi Member

    Actually, there was one strange thing that happened during my import. Certain parts of my import were imported multiple times. For instance, forums got imported twice, once with posts, once without. I got 4 copies of all usergroups. What I may do is do a fresh install since I tried doing a fresh import after I got a memory allocation error.

    I'll probably try that first since it makes more sense to see if this works on a 'correct' import vs one that seems to be a bit broken. Although I don't think this is part of the issue, I have gone from vB4 -> IPB 3.1.2 so it's not a native IPB3.1.2 database.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yeah, definitely run a new import. In general it's not a good idea to run the same import multiple times on the same database because there is no easy way to deal with duplicate content. You should reinstall XenForo if you want to run the import again.

    And yes, you should use the official IPB importer now that it's available.

Share This Page