• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot reproduce "Likes" are fluctuating

XenStyle

Active member
#1
I have gotten an odd report from a few members now, that it seems their "Likes" count is fluctuating. For example, it will drop 20 or so, and a few hours later will go back to normal. Threads are not being deleted or purged in any way, and I have gotten the same complaint from 3 different people now. I am not sure how to even go about recreating the bug, but I was wondering if this was a known issue.

I just upgraded my board to 1.2 two days ago.
 

XenStyle

Active member
#3
I do realize this, however, I do not think it is the case. It would be a large coincidence that multiple members are reporting the issue since I updated to 1.2 a few days ago. Maybe I need some more concrete evidence to narrow it down, but it has never been a problem before.

A quote from a member about the issue:
I've seen it go 690 - 670 - 702 -683 in the past 2 days
The other complaints were similar, and this behavior is not a usual occurrence.
 

Jeremy

Well-known member
#6
Can you reproduce this yourself? Or with add-ons disabled? Have these users received alerts for the jump in likes?
 

XenStyle

Active member
#7
Can you reproduce this yourself? Or with add-ons disabled? Have these users received alerts for the jump in likes?
It is so unpredictable at this point, that I do not know where to start to reproduce the problem. I have not tried with add-ons disabled, as this is a last resort (knowing that it could take a few days to see if the problem persists). As for alerts, I can confirm that they did not get alerts for the added likes (great question!). I will try to collect some more information about the problem.
 

Mike

XenForo developer
Staff member
#8
I will note that XF generally manipulates the like count using +1 or -1 type values, so I don't see how this could happen unless content was being deleted/undeleted.