• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Like Listings Overlay Broken (Media and Albums Likes Summary)

Amaury

Well-known member
#1
If I like a media item that already has at least three likes and click on "X other person / others," the like listings overlay appears broken:

upload_2014-11-12_9-37-1.png

I have to refresh the page to rectify the issue.
 
Last edited:

Amaury

Well-known member
#6
Can you reproduce it every time? Any particular steps?
Yes.

As for the steps:
  1. Go to a media item that has at least three likes
  2. Like the item
  3. It'll appear as "You, A, B, and 1 other person / X others like this"
  4. Click on "1 other person / X others like this"
  5. The overlay appears broken

If you already liked an item, clicking unlike will result in the same issue.

Refreshing the page makes it appear correctly.
 

Chris D

XenForo developer
Staff member
#11
The URL used on the likes_summary template should have been defined as 'xengallery/likes' or for albums 'xengallery/albums/likes' but, the 'likes' part was missing, hence the likes_summary link actually pointed back at the content; hence why in your screenshot you saw the media item try to load again in an overlay rather than the actual likes summary.
 

Amaury

Well-known member
#12
The URL used on the likes_summary template should have been defined as 'xengallery/likes' or for albums 'xengallery/albums/likes' but, the 'likes' part was missing, hence the likes_summary link actually pointed back at the content; hence why in your screenshot you saw the media item try to load again in an overlay rather than the actual likes summary.
Ah, I see. So how did refreshing the page make it appear properly?
 

Chris D

XenForo developer
Staff member
#13
It specifically relates to the AJAX action that updates the content of the page. That action was replacing the correct link with the incorrect link.