• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed  Like bug

erich37

Well-known member
#1
not sure if you saw this, as I posted this after you set my previous bug-report to resolved?

so as said, I have deleted a user from my system which actually liked a Forum-post.
Now another person (her name is Claudia) "liked" the same post.

Now the name of the specific user which I deleted is not appearing anymore (no idea why). Which is actually great, but it looks a bit strange as the word "and" is still showing up.

Please see the screenshot below:

bug_deleted_user_like.png like_bug.png people_like.png
 

Fufu

Well-known member
#4
The 'and' should be removed.

If 1 people, should change to the single user's name.

Also, more than 1 should have 'liked'.

Good catch.
 

erich37

Well-known member
#5
The 'and' should be removed.

If 1 people, should change to the single user's name.

Also, more than 1 should have 'liked'.

Good catch.
It actually says "1 people like this" because I have deleted this user from my system.
Meaning: the user who liked this post was a spammer and I deleted this person from ACP.
 
R

ragtek

Guest
#6
I have a other result:D

Testuser1 (ajnos1) liked my post.

Then i deleted the user.
In the post i have still "ajnos1 likes this", but in the alert popup, the name is missing.
bug.PNG

Once somebody else likes this too, it's like described in post1.
bug2.PNG

It's because the deleted users likes aren't deleted. (also not the like_users) in the content table, but i fear that this would be a heavy query... I wouldn't run this, because AFAIK it's rebuild if somebody likes/unlikes the content.
 

Kier

XenForo Developer
Staff member
#7
First part fixed, second part probably won't fix as it's a massive edge case and doesn't really impede usability.