XF 2.0 Missing Like Buttons, odd permissions changes


Well-known member
I just performed a 1.x upgraded to 2.0 as the first part of my upgrades. I've noticed that the Like button has disappeared from forums. Going to user groups and individual permissions I see a strange setup where many permissions seem reversed (no, rather than yes) in my permissions. Not sure how this occurred and wondered if those have seen this behavior. After turning on Likes everywhere I can (to yes), they still do not appear. Wondering if anyone has encountered this and whether the next stage (upgrading to 2.2.x) might resolve some of these anomalies. Thank you for all feedback.
I've done many 1.x to 2.x upgrades and never seen any issues with permissions changing or features being removed.

Is there any reason why you didn't just upgrade directly to 2.2?
Excellent question. Made a little pit stop to convert custom fields, which worked like a charm. I'm going to follow through now. So far almost everything looks good and the above was the odd temporary functionality loss. Regarding the data, I know it is still there because the Likes are still registered and you can see the Liked history visible in the threads. Fixing permissions and troubleshooting this looks like small speed bumps, just trying to iron these out before the big migration this week (which will be more than just the forums, articles, etc.) Thanks.

Problem solved. Each update and addon is installing with all defaults set to "No" and some of the sections weren't set because the little arrow was pointed sideways and I didn't realize that it was collapsed and not set. After expanding them and setting all properly, it works as expected. I'm going to have to manually reset up permissions but this might be a good time to do proper housekeeping.
Top Bottom