1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Language after import is incorrect

Discussion in 'Installation, Upgrade, and Import Support' started by Moshe1010, Aug 2, 2013.

  1. Moshe1010

    Moshe1010 Well-Known Member

    After I've imported from vB 4.2.1, I've uploaded my language XML in addition to the English that was there in the first place. I've chosen my language XML to be the default for the entire system, however, it looks like all the imported members have English as their default after they log-in the first time to XF.
    I'f I'm a guest, I see the entire system in my own language. If I register as a new member, same thing, I can see the entire system in my own language. Any ideas?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You can run a query to update the user prefs:

    UPDATE xf_user
    SET language_id = 1
    Specify the id.
  3. Moshe1010

    Moshe1010 Well-Known Member

    Shouldn't it import the language preferences as well? Or because it's a new language then it's impossible? (new = new XML file, the language is the same)
  4. Mike

    Mike XenForo Developer Staff Member

    It can't import the language preference because it doesn't import the language. As such, they will just use the default language you've chosen in XF. I'm not sure why it's not working this way for you.
  5. Moshe1010

    Moshe1010 Well-Known Member

    The default language was my language and still all of the members were on English. Anyway, I run the query and it's fine now - thanks.

Share This Page