1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Keep getting Internal Server Error when viewing forums or revuilding templates/cache

Discussion in 'Troubleshooting and Problems' started by XxUnkn0wnxX, Feb 3, 2014.

  1. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    sorry that i misspelled the title it was suppose to say rebuilding templates/cache

    i don't know what is going on here

    i upgraded to php 5.4.x not long ago and thats when i started getting these issues!

    i also run FastCGI now not suphp handlers

    Code:
    Internal Server Error
    
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator, webmaster@portalcentric.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    [​IMG]

    This is my apache set up:

    [​IMG]

    [​IMG]

    could it be because i have something missing?

    i also have all of these beta ones
    [​IMG]

    [​IMG]

    if this is the wrong section, i am sorry but me and my members are getting really annoyed...
     
    Last edited: Feb 3, 2014
  2. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    and i am not reviving any errors in any my error logs i have been through them all.

    and this what i have set up in all the htaccess file i have

    public_html folder:
    Code:
    #The top of your .htaccess file
    ServerSignature Off
    RewriteEngine On
    IndexIgnore *
    
    # Protect your .htaccess file
    <Files .htaccess>
            order allow,deny
            deny from all
    </Files>
    
    ErrorDocument 400 default
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    # BEGIN WordPress
         RewriteCond %{REQUEST_FILENAME} !-f
         RewriteCond %{REQUEST_FILENAME} !-d
         RewriteRule . /index.php [L]
    # END WordPress
    
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?portalcentric.net [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?duckduckgo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?bing.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yahoo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?xenforo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?twitter.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?netdna-cdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?maxcdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?cloudflare.com [NC]
    RewriteRule \.(jpg|jpeg|png|gif|bmp|tiff|pic|mp3|doc|xls|mpeg|mpg|ram|rm|wma|wav|asx|wmv|avi|mov|zip|rar|exe)$ http://oi41.tinypic.com/2wq73lx.jpg [NC,R,L]
    
    
    # the last re-write rules #
    
    # stop script kiddies #
    
    RewriteCond %{REQUEST_METHOD} ^(HEAD|TRACE|DELETE|TRACK) [NC,OR]
    RewriteCond %{THE_REQUEST} (\\r|\\n|%0A|%0D) [NC,OR]
    RewriteCond %{HTTP_REFERER} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{HTTP_COOKIE} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{REQUEST_URI} ^/(,|;|:|<|>|”>|”<|/|\\\.\.\\).{0,9999} [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^$ [OR]
    RewriteCond %{HTTP_USER_AGENT} ^(java|curl|wget) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (winhttp|HTTrack|clshttp|archiver|loader|email|harvest|extract|grab|miner) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (libwww-perl|curl|wget|python|nikto|scan) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    #Block mySQL injects
    RewriteCond %{QUERY_STRING} (;|<|>|’|”|\)|%0A|%0D|%22|%27|%3C|%3E|%00).*(/\*|union|select|insert|cast|set|declare|drop|update|md5|benchmark) [NC,OR]
    RewriteCond %{QUERY_STRING} \.\./\.\. [OR]
    RewriteCond %{QUERY_STRING} (localhost|loopback|127\.0\.0\.1) [NC,OR]
    RewriteCond %{QUERY_STRING} \.[a-z0-9] [NC,OR]
    RewriteCond %{QUERY_STRING} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC]
    # Note: The final RewriteCond must NOT use the [OR] flag.
    
    # Block undesirables by user-agent
    RewriteCond %{HTTP_USER_AGENT} ^bot [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} grub [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} holmes [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} naver [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Nutch [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Pete-Spider [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} SBIder [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Seekbot [NC,OR]
    
    # The last item in the list must not have an OR
    RewriteCond %{HTTP_USER_AGENT} wget [NC]
    
    # Feed them all a 403 Forbidden
    RewriteRule .* - [F]
    
    # the last re-write rules #
    
    ErrorDocument 401 "Authorization Required"
    Forums (Xenforo) Folder:
    Code:
    #The top of your .htaccess file
    ServerSignature Off
    RewriteEngine On
    IndexIgnore *
    
    # Protect your .htaccess file
    <Files .htaccess>
            order allow,deny
            deny from all
    </Files>
    
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 400 default
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        RewriteCond %{HTTP_HOST} ^www.portalcentric.net/forums$ [NC]
        RewriteRule ^(.*)$ http://portalcentric.net/forums/$1 [R=301,L]
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /forums
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?portalcentric.net [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?duckduckgo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?bing.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yahoo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?xenforo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?twitter.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?netdna-cdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?maxcdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?cloudflare.com [NC]
    RewriteRule \.(jpg|jpeg|png|gif|bmp|tiff|pic|mp3|doc|xls|mpeg|mpg|ram|rm|wma|wav|asx|wmv|avi|mov|zip|rar|exe)$ http://oi41.tinypic.com/2wq73lx.jpg [NC,R,L]
    
    # the last re-write rules #
    
    # stop script kiddies #
    
    RewriteCond %{REQUEST_METHOD} ^(HEAD|TRACE|DELETE|TRACK) [NC,OR]
    RewriteCond %{THE_REQUEST} (\\r|\\n|%0A|%0D) [NC,OR]
    RewriteCond %{HTTP_REFERER} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{HTTP_COOKIE} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{REQUEST_URI} ^/(,|;|:|<|>|”>|”<|/|\\\.\.\\).{0,9999} [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} ^$ [OR]
    RewriteCond %{HTTP_USER_AGENT} ^(java|curl|wget) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (winhttp|HTTrack|clshttp|archiver|loader|email|harvest|extract|grab|miner) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (libwww-perl|curl|wget|python|nikto|scan) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    #Block mySQL injects
    RewriteCond %{QUERY_STRING} (;|<|>|’|”|\)|%0A|%0D|%22|%27|%3C|%3E|%00).*(/\*|union|select|insert|cast|set|declare|drop|update|md5|benchmark) [NC,OR]
    RewriteCond %{QUERY_STRING} \.\./\.\. [OR]
    RewriteCond %{QUERY_STRING} (localhost|loopback|127\.0\.0\.1) [NC,OR]
    RewriteCond %{QUERY_STRING} \.[a-z0-9] [NC,OR]
    RewriteCond %{QUERY_STRING} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC]
    # Note: The final RewriteCond must NOT use the [OR] flag.
    
    # Block undesirables by user-agent
    RewriteCond %{HTTP_USER_AGENT} ^bot [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} grub [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} holmes [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} naver [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Nutch [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Pete-Spider [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} SBIder [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Seekbot [NC,OR]
    
    # The last item in the list must not have an OR
    RewriteCond %{HTTP_USER_AGENT} wget [NC]
    
    # Feed them all a 403 Forbidden
    RewriteRule .* - [F]
    
    # the last re-write rules #
    
    ErrorDocument 401 "Authorization Required"
     
  3. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    Forums (Xenforo) Library Folder:

    Code:
    #The top of your .htaccess file
    ServerSignature Off
    RewriteEngine On
    IndexIgnore *
    
    # Protect your .htaccess file
    <Files .htaccess>
            order allow,deny
            deny from all
    </Files>
    
    ErrorDocument 400 default
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?portalcentric.net [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?duckduckgo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?bing.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yahoo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?xenforo.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?twitter.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?netdna-cdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?maxcdn.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?cloudflare.com [NC]
    RewriteRule \.(jpg|jpeg|png|gif|bmp|tiff|pic|mp3|doc|xls|mpeg|mpg|ram|rm|wma|wav|asx|wmv|avi|mov|zip|rar|exe)$ http://oi41.tinypic.com/2wq73lx.jpg [NC,R,L]
    
    # the last re-write rules #
    
    # stop script kiddies #
    
    RewriteCond %{REQUEST_METHOD} ^(HEAD|TRACE|DELETE|TRACK) [NC,OR]
    RewriteCond %{THE_REQUEST} (\\r|\\n|%0A|%0D) [NC,OR]
    
    RewriteCond %{HTTP_REFERER} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{HTTP_COOKIE} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    RewriteCond %{REQUEST_URI} ^/(,|;|:|<|>|”>|”<|/|\\\.\.\\).{0,9999} [NC,OR]
    
    RewriteCond %{HTTP_USER_AGENT} ^$ [OR]
    RewriteCond %{HTTP_USER_AGENT} ^(java|curl|wget) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (winhttp|HTTrack|clshttp|archiver|loader|email|harvest|extract|grab|miner) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (libwww-perl|curl|wget|python|nikto|scan) [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC,OR]
    
    #Block mySQL injects
    RewriteCond %{QUERY_STRING} (;|<|>|’|”|\)|%0A|%0D|%22|%27|%3C|%3E|%00).*(/\*|union|select|insert|cast|set|declare|drop|update|md5|benchmark) [NC,OR]
    
    RewriteCond %{QUERY_STRING} \.\./\.\. [OR]
    
    RewriteCond %{QUERY_STRING} (localhost|loopback|127\.0\.0\.1) [NC,OR]
    RewriteCond %{QUERY_STRING} \.[a-z0-9] [NC,OR]
    RewriteCond %{QUERY_STRING} (<|>|’|%0A|%0D|%27|%3C|%3E|%00) [NC]
    # Note: The final RewriteCond must NOT use the [OR] flag.
    
    # Block undesirables by user-agent
    RewriteCond %{HTTP_USER_AGENT} ^bot [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} grub [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} holmes [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} naver [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Nutch [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Pete-Spider [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} SBIder [NC,OR]
    RewriteCond %{HTTP_USER_AGENT} Seekbot [NC,OR]
    
    # The last item in the list must not have an OR
    RewriteCond %{HTTP_USER_AGENT} wget [NC]
    
    # Feed them all a 403 Forbidden
    RewriteRule .* - [F]
    
    # the last re-write rules #
    
    ErrorDocument 401 "Authorization Required"
     
  4. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    o i also have mod page speed installed
     
  5. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    please help i cannot install or update an add ones with this error happening each time. it like tries to execute a command like when i press update or check updates and it spits out the error
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    We need to see the contents of the server log to see what is triggering it.

    Without some more details it's impossible to tell.
     
  7. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    i am not 100% sure where that is as i have many server logs for every single process i run, but i will try my best
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    It will be something like var/log/error_log or similar.
     
  9. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    Code:
    [Tue Feb 04 01:17:56 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 01:17:12 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 01:16:42 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 01:16:26 2014] [error] [client ?] (36)File name too long: access to /forums/js/xenforo,_news_feed.js,,q_v==5ce02b23,Mjm.WkvKOMbTV0.js+merc,_donation_manager.js,,q_v==5ce02b23,Mjm.scxctE4gaF.js+sedo,_toggleme,_toggleME.js,q1387879354,a_v==5ce02b23+sedo,_tinyquattro,_integration,_retro_header.js,q_v==5ce02b23.pagespeed.jc.eMHagxdEMS.js failed (filesystem path '/home/unkn0wn/public_html/forums/js/xenforo,_news_feed.js,,q_v==5ce02b23,Mjm.WkvKOMbTV0.js+merc,_donation_manager.js,,q_v==5ce02b23,Mjm.scxctE4gaF.js+sedo,_toggleme,_toggleME.js,q1387879354,a_v==5ce02b23+sedo,_tinyquattro,_integration,_retro_header.js,q_v==5ce02b23.pagespeed.jc.eMHagxdEMS.js')
    [Tue Feb 04 01:07:44 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 01:04:23 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:57:37 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:56:48 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/data/MetaMirrorCache/attachments, referer: http://portalcentric.net/forums/threads/project-memories-v2-0-1-24-mod-menu.131/
    [Tue Feb 04 00:45:12 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:44:50 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:11:48 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:10:44 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Tue Feb 04 00:06:09 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    [Mon Feb 03 23:58:03 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/data/avatars/s/0/20.jpg?1390748249
    [Mon Feb 03 23:50:53 2014] [error] [client ?] File does not exist: /home/unkn0wn/public_html/forums/styles/fusiongamer/xenforo/images/logo.og.png
    i removed the client ips and replaced with ?, this all from today.. but i will try to find some others...
     
  10. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ok i have a error_log in my forums folder, public html folder and my unknw0n folder, and on the server they massive as like 500mb +
     
  11. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    found some more but i don't think they related, anything by waindigo is either outdated log cozz i have them disabled

    Code:
    [28-Jan-2014 10:05:16 CST6CDT] PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [28-Jan-2014 10:05:16 CST6CDT] PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [29-Jan-2014 00:44:22 UTC] PHP Fatal error:  Maximum execution time of 45 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [29-Jan-2014 02:36:30 UTC] PHP Fatal error:  Maximum execution time of 45 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:43:12 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:49:09 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:50:43 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [02-Feb-2014 10:23:35 UTC] PHP Fatal error:  Call to undefined method Waindigo_EmailAlerts_Extend_XenForo_Model_UserUpgrade::notifyUsersOfExpiringUpgrades() in /home/unkn0wn/public_html/forums/library/Waindigo/UserUpgrades/CronEntry/UserUpgradeExpiryNotification.php on line 14
    
    Code:
    [02-Feb-2014 07:30:27 UTC] PHP Warning:  Creating default object from empty value in /home/unkn0wn/public_html/wp-content/plugins/et-shortcodes/et-shortcodes.php on line 135
    [02-Feb-2014 19:21:12 UTC] PHP Warning:  Creating default object from empty value in /home/unkn0wn/public_html/wp-content/plugins/et-shortcodes/et-shortcodes.php on line 135
    
    Code:
    [28-Jan-2014 10:05:16 CST6CDT] PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [28-Jan-2014 10:05:16 CST6CDT] PHP Warning:  Module 'imagick' already loaded in Unknown on line 0
    [29-Jan-2014 00:44:22 UTC] PHP Fatal error:  Maximum execution time of 45 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [29-Jan-2014 02:36:30 UTC] PHP Fatal error:  Maximum execution time of 45 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:43:12 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:49:09 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [30-Jan-2014 12:50:43 UTC] PHP Fatal error:  Maximum execution time of 60 seconds exceeded in /home/unkn0wn/public_html/forums/library/XenForo/Image/ImageMagick/Pecl.php on line 265
    [02-Feb-2014 10:23:35 UTC] PHP Fatal error:  Call to undefined method Waindigo_EmailAlerts_Extend_XenForo_Model_UserUpgrade::notifyUsersOfExpiringUpgrades() in /home/unkn0wn/public_html/forums/library/Waindigo/UserUpgrades/CronEntry/UserUpgradeExpiryNotification.php on line 14
    
    still trying to find more. but all this i think is unrelated
     
  12. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    i started like i said having these issues when i upgraded to php 5.4.x and i use APC cache system as back end to xenforo but i still got errors even when i removed it from the config file... and cleaned cache
     
  13. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    i cannot seem to find any other logs in relation to this.. just curios could it be how i set up my htaccess files?

    if so maybe take a look?

    although

    i do need this:
    RewriteBase /forums

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

    without it i get like 404 errors page not found on the forums when people try to login or register. its like the /login = doesn't go any where goes to it as a directory and there is no directory called login...

    but the above fix it up..
     
  14. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ok i couldn't see anything in the logs but i found the problem

    APC doesn't fully work well with php 5.4, well it does work but i need to configure it to stop caching the admin.php

    also is there anything related to admin.php? like if i want it to stop cahceing the admin part of xenfroro what folders and files to i make it not touch?

    also it could be something else like, may need to be re installed with svn trunk and people say to make it cache using the users home directory folder well a tmp folder in that not the tmp folder on the server.


    atm my APC is off:

    Code:
    ;APC Configuration
    apc.enabled = 0
    apc.shm_segments = 1
    
    ;32M per WordPress install
    apc.shm_size = 256M
    
    ;Relative to the number of cached files (you may need to watch your stats for a day or two to find out a good number)
    apc.num_files_hint = 7000
    
    ;Relative to the size of WordPress
    apc.user_entries_hint = 4096
    
    ;The number of seconds a cache entry is allowed to idle in a slot before APC dumps the cache
    apc.ttl = 7200
    apc.user_ttl = 7200
    apc.gc_ttl = 3600
    
    ;Setting this to 0 will give you the best performance, as APC will
    ;not have to check the IO for changes. However, you must clear
    ;the APC cache to recompile already cached files. If you are still
    ;developing, updating your site daily in WP-ADMIN, and running W3TC
    ;set this to 1
    apc.stat=1
    
    ;This MUST be 0, WP can have errors otherwise!
    apc.include_once_override=0
    
    ;Only set to 1 while debugging
    apc.enable_cli = 0
    
    ;Allow 2 seconds after a file is created before it is cached to prevent users from seeing half-written/weird pages
    apc.file_update_protection = 2
    
    ;Leave at 2M or lower. WordPress does't have any file sizes close to 2M
    apc.max_file_size = 74M
    
    ;Ignore files
    apc.filters = "/home/unkn0wn/public_html/apc/apc.php"
    apc.filters = "/home/unkn0wn/public_html/testboard/admin.php"
    apc.filters = "/home/unkn0wn/public_html/forums/admin.php"
    
    
    apc.cache_by_default = 1
    apc.use_request_time=1
    apc.slam_defense = 0
    apc.mmap_file_mask = "/tmp/apc.XXXXXX"
    apc.stat_ctime=0
    apc.canonicalize=0
    apc.write_lock=1
    apc.report_autofilter=0
    apc.rfc1867=0
    apc.rfc1867_prefix =upload_
    apc.rfc1867_name=APC_UPLOAD_PROGRESS
    apc.rfc1867_freq=0
    apc.rfc1867_ttl=3600
    apc.lazy_classes=0
    apc.lazy_functions=0
    apc.optimization = 1
    apc.localcache = 0
    apc.localcache.size = 2048
    apc.coredump_unmap = 0
    
    originals all the config is suppose to be in apc.ini but i never found it on my server so i placed this config in php.ini and turned it off from the ini

    so maybe i have some thing misconfiguration here. because errors i got said there was a misconfiguration.
    not sure what i done wrong here...
     

Share This Page