• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Javascript error [SOLVED]

#1
Greetings,

I have just finished a very long upgrade (took almost 5 days) on a huge board from vb3 to xf. Everything went fine, it was just a huge amount of data to be converted.

After installing the latest version of xf I noticed that whenever I hover on top of the dropdown next to my name or whenever I want to switch styles I get the message:

The server responded with an error. The error message is in the JavaScript console.

I checked some of the existing topics in this board but nothing struck out to identify the problem. The only plugin installed is the xf media gallery. I disabled that but the problem still persists.

Looking at the console, it seems that I am getting a whole page back (highlighted in red in the console) instead of just the data for the particular area that the JS needs to show.

I see the request like so:

/conversations/popup?&_xfRequestUri=%2F&_xfNoRedirect=1&_xfToken=...&_xfResponseType=json

and the response comes in as a full HTML page

<!DOCTYPE html>
<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs GalleryLazyLoader LoggedIn NoSidebar Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="utf-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
....
</body>
</html>

Any pointers are more than welcome
 

Mike

XenForo developer
Staff member
#3
You have a configuration with your server that appears to be causing it to ignore query string parameters. You can see this by attempting to use the headers at the top of the thread list to sort in a different order; they don't work.