• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Javascript Error Messages

#1
Hi, I'm Italian and I do not speak English well.
I bought "XenForo" a few days. I am happy with the choice, I find a great product like and in some cases superior to other board fee.

I have a small problem though, when I click on profiles, I check an error popup that says:

"Be careful, I encountered an error
The server responded with an error. The error message is in the JavaScript console. "

I made a screenshot to better understand:



May depend on what? My board at the following address: community.tvdream.net so that you also check the error.


Thank you all for any replies.
 
#3
Thanks for the answer. I use nginx. I think the problem is this:

I wanted to disappear "index.php" from the URL of the pages, so I turned on the options the "Friendly URL" and the configuration of my web server nginx I set these values:


location / {
root /var/www/mysite/subdomains/community;
index index.html index.htm index.php;
try_files $uri $uri/ /index.php;
}


Now I have removed the line "try_files $uri $uri/ /index.php;" and now it works, there are no javascript errors.

How do then to remove "index.php" from URLs?

Thanks.
 
#5
Perfect, now everything is working correctly. Here's the configuration:

location / {
root /var/www/mysite/subdomains/community;
index index.php index.html index.htm;
if (!-e $request_filename) {
rewrite ^(.*)$ /index.php last;
}
}
 

tmb

Active member
#7
Getting the same error now since I've updated from 1.0.0 to 1.0.1. I can't post at all and get that
The server responded with an error. The error message is in the JavaScript console. Didn't have this issue before.