1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 javascript console error after new server and upgrade to 1.4

Discussion in 'Troubleshooting and Problems' started by electrogypsy, Sep 27, 2014.

  1. electrogypsy

    electrogypsy Active Member

    so, i just moved to digital ocean from linode, and things were fine, but now that i upgraded from 1.3.5 to 1.4.1, i'm getting javascript console errors on pretty much everything. profile post tabs, alerts dropdown, etc.

    here's what's in my console from chrome:

    ....well... apparently i can't copy and paste the whole code in, since xenforo.com gives me an error message saying my post is too long...

    so i'll just post the end part that looks the most important:

    </html> xenforo.js,q_v=f2ea9e93.pagespeed.jm._FBhmR9894.js:1c.extend.handleServerError xenforo.js,q_v=f2ea9e93.pagespeed.jm._FBhmR9894.js:1c.extend.error xenforo.js,q_v=f2ea9e93.pagespeed.jm._FBhmR9894.js:1j jquery.min.js:2k.fireWith jquery.min.js:2x jquery.min.js:4b jquery.min.js:4
    XenForo.activate([div.xenOverlay.__XenForoActivator, prevObject: e.fn.init[1], context: undefined, jquery: "1.11.0", constructor: function, selector: ""…]) xenforo.js,q_v=f2ea9e93.pagespeed.jm._FBhmR9894.js:1
    i've never had this problem before, so i'm not sure how to go about fixing it. any suggestions would be awesome :)

    oh, and for reference, i'm using centminmod on centos 6.5 with xenforo 1.4

    and if you wanna poke around my website to see the error, it's http://squattheplanet.com
  2. electrogypsy

    electrogypsy Active Member

    so far, it looks like pretty much all the javascript on my website is broken.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried running a file health check?
    Uploaded the .zip package files again?
  4. Liam W

    Liam W Well-Known Member

    It looks like your site is always returning HTML, and not the expected json.

    You should do what @Brogan said - reupload all files in the upgrade package.

  5. electrogypsy

    electrogypsy Active Member

    yeah, the file health check comes back good, and i've re-uploaded the files from 1.4 still with the same results. is there something else i can check?
  6. Chris D

    Chris D XenForo Developer Staff Member

    Disable all add-ons and try again.
  7. electrogypsy

    electrogypsy Active Member

    unfortunately i already tried that... i disabled all plugins by editing the config.php and still had the same problem.
  8. Chris D

    Chris D XenForo Developer Staff Member

    I notice reference to pagespeed in the original post. Is this something you can toggle off? It may be related. I think it defers and perhaps further minifies the javascript so it could have an impact.
  9. Robust

    Robust Well-Known Member

    This may be a wild goose chase, but I notice a reference to pagespeed to. Perhaps this? http://centminmod.com/nginx_ngx_pagespeed.html It may be included in your mod. Try disabling it if it is.

    Also, using pastebin.com for the entire error would be helpful.
  10. Liam W

    Liam W Well-Known Member

    You can see the 'error' yourself by going to their site - although the error isn't really an error, it's just the entire HTML page that would be returned if the link had been accessed directly...
  11. Robust

    Robust Well-Known Member


Share This Page