1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Issue with starting Private conversation

Discussion in 'Troubleshooting and Problems' started by mono, Sep 10, 2013.

  1. mono

    mono Active Member

    Hello. Some of my users can't start a conversation with any user despite all permissions set right. It even doesn't depend on user group. It may work and may don't work with different users within one user group.
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Are there any errors shown or logged? Does it happen with specific users? If its specific users, do they accept PCs?
     
  3. mono

    mono Active Member

    No errors at all. It happened with one of my super-moderator.
     
    Last edited: Sep 10, 2013
  4. AndyB

    AndyB Well-Known Member

    PC = Private Conversation.
     
    mono likes this.
  5. mono

    mono Active Member

    @AndyB Thank you, now I see.
    @Jeremy It happens with all users If for example I've loged with this account.
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    What is the "Initiate conversations with this user" setting? Edit your super moderator and look under "Privacy".
     
  7. AndyB

    AndyB Well-Known Member

    Have you been able to duplicate the problem on your forum?

    What exactly happens when the member clicks the Start a New Conversation link?
     
  8. mono

    mono Active Member

    Members Only
    Actually, I had other users with the same problem, which then disappeared somehow.
    There is no conversation link.
     
  9. Mike

    Mike XenForo Developer Staff Member

    If they don't get the link (I'm assuming the "start new conversation" link under the "Inbox" popup), then the system doesn't think they have permission. This is exactly what's checked:
    • That they are a valid user (not awaiting email confirmation or approval)
    • That they have permissions to start conversations
    • That the maximum conversation recipients is greater than 0.
     
    Fred. and mono like this.
  10. mono

    mono Active Member

    That is the solution. Thank you Mike for describing it! Sorry if I've not looked so carefully for permissions.
     

Share This Page