Issue with smilies following update to 2.2.8

webbouk

Well-known member
Affected version
2.2.8
When posting and adding a smilie using Firefox on a PC the cursor position cannot be placed after the smilie in the post but instead is placed in front of it meaning that if you want to continue typing after the smilie it is impossible without moving the smilie to the end of the type.

This doesn't happen using Chrome, the cursor can be placed before or after the smilie, as prior the update.

See below:

Top using Firefox (on here)
Bottom using Chrome (on here)
| shows the position of the cursor

1638691941175.png
 

ge66

Well-known member
Tested myself in firefox, for me the cursor is placed after the smilie but if I then place the cursor somewhere else in the text it then is impossible to place it after the smilie.
 

webbouk

Well-known member
I've just had an auto update of Firefox to v95.0.0 and the issue still arises.

If you type in the actual code for the smilie it works as intended, however if you use the 'Smilies' image that's when the issue shows. (n)
 

FTL

Well-known member
Yes, I've noticed that too. Using Firefox here, not tried another browser. Bit of a pita, isn't it?
 

ge66

Well-known member
I have tested and the bug is present here on this site using firefox 94.0.2 on macOS 12.0.1 M1
Also tested in ubuntu under parallels on the same mac, firefox 95.0 at first it worked but after clicking after and before the smilie it is not possible to click and get the cursor after the smilie.
 

webbouk

Well-known member
I've found it's not just limited to smilies, but it also affects any picture uploaded .... and the same on this forum....

blue-loading-gif-transparent - Copy.gif
 

Chris D

XenForo developer
Staff member
We've updated to the latest Froala release. I'm pretty sure I could previously reproduce this in Firefox, but I no longer seem to be able to.

Can someone please confirm and, if you can still reproduce it, please write the specific steps to make sure I'm not overlooking anything?
 

swiftyste

Active member
Yeah this is still here driving us crazy.

  • Place a smiley ;)
  • Then the "Typing Cursor" starts from before the smiley.
When you try to move the "Typing Cursor" it stays where it is you either:

  • Pressing down on "keyboard arrows"
  • Try to move "Typing Cursor" but (more than likely move back to before the smiley)
This happens on Firefox early versions & also the daily nightly beta versions.
 
Top