• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.0 Issue with personal messages

Marc

Well-known member
#1
Seem to have a problem when sending messages, but not a clue as to what is causing it. Now its happened before but extremely infrequently, however has happened a fair few times today.

When sending the following error is logged:
Non-recipients cannot reply to a conversation

The strange thing is the message is actually sent, even though the user recieves the generic server error message. So the recipient ends up with several messages.

Details show the following:



Error Info​
XenForo_Exception: Non-recipients cannot reply to a conversation. - library/XenForo/DataWriter/ConversationMessage.php:104
Generated By: Mazz, Wednesday at 12:29 AM

Stack Trace​

#0 /home/huskyown/public_html/forum/library/XenForo/DataWriter.php(1331): XenForo_DataWriter_ConversationMessage->_preSave() #1 /home/huskyown/public_html/forum/library/XenForo/DataWriter.php(1271): XenForo_DataWriter->preSave() #2 /home/huskyown/public_html/forum/library/ConversationAttachments/ControllerPublic/Conversation.php(63): XenForo_DataWriter->save() #3 /home/huskyown/public_html/forum/library/XenForo/FrontController.php(310): ConversationAttachments_ControllerPublic_Conversation->actionInsert() #4 /home/huskyown/public_html/forum/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch)) #5 /home/huskyown/public_html/forum/index.php(13): XenForo_FrontController->run() #6 {main}

Request State​

array(3) { ["url"] => string(54) "http://www.husky-owners.com/forum/conversations/insert" ["_GET"] => array(0) { } ["_POST"] => array(9) { ["recipients"] => string(9) "Mistyrayn" ["title"] => string(29) "Moved "Over 18's Only" thread" ["message_html"] => string(368) "<p>Richard,</p> <p>&nbsp;</p> <p>I've moved the subject thread off the main forum.&nbsp; I don't feel it is appropriate, given that there are those under 18 on the forum, and the title alone will peak the interest of those in that age group.&nbsp; If staff feels there's not an issue, I will put it back and let you know.</p> <p>&nbsp;</p> <p>Mazz</p> <p>Moderator</p>" ["_xfRelativeResolver"] => string(64) "http://www.husky-owners.com/forum/conversations/add?to=Mistyrayn" ["attachment_hash"] => string(32) "cba4127ea9721714eab2433e54ace80b" ["_xfToken"] => string(55) "320,1318375605,dde5881a662b7bf80da3024cee294aab4e993878" ["_xfRequestUri"] => string(37) "/forum/conversations/add?to=Mistyrayn" ["_xfNoRedirect"] => string(1) "1" ["_xfResponseType"] => string(4) "json" } }
 

Mike

XenForo developer
Staff member
#2
Looks like it's caused by the conversation attachments add-on:
/home/huskyown/public_html/forum/library/ConversationAttachments/ControllerPublic/Conversation.php(63): XenForo_DataWriter->save() #3
Which of course needs to be removed before upgrading to 1.1