• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

IPB 3.4 to Xenforo 1.4.3

Linkzy

Active member
#1
Hello!

I've tried the import admin cp on xenforo my forum... But i cant seem to import any data... The data IPB hosted on a different webhost and the xenforo forum I have installed is on a different webhost too. Now I'm trying to merge the users/posts/threads all that stuff to my new xenforo forum. How can i do it please?

I tried the importer but this error i get.
Code:
An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/post4fun/public_html/library/Zend/Db/Statement/Mysqli.php on line 77

Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
XenForo_Model->fetchAllKeyed() in XenForo/Model/AdminNavigation.php at line 31
XenForo_Model_AdminNavigation->getAdminNavigationEntries() in XenForo/Model/AdminNavigation.php at line 405
XenForo_Model_AdminNavigation->getAdminNavigationForDisplay() in XenForo/Dependencies/Admin.php at line 224
XenForo_Dependencies_Admin->_getNavigationContainerParams() in XenForo/Dependencies/Admin.php at line 202
XenForo_Dependencies_Admin->getEffectiveContainerParams() in XenForo/FrontController.php at line 616
XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
XenForo_FrontController->run() in /home/post4fun/public_html/admin.php at line 13
 

Brogan

XenForo moderator
Staff member
#4
Copy the IPB database and attachments/avatars to the same server/MySQL which XenForo is installed on.
Then perform the import.
 

Linkzy

Active member
#6
SQL query:

CREATE TABLE jlogica_awards(

id INT( 8 ) NOT NULL AUTO_INCREMENT ,
name VARCHAR( 255 ) NOT NULL ,
DESC VARCHAR( 255 ) NOT NULL ,
descno VARCHAR( 255 ) NOT NULL ,
longdesc TEXT NOT NULL ,
icon VARCHAR( 50 ) NOT NULL ,
placement INT( 2 ) NOT NULL ,
parent INT( 8 ) NOT NULL ,
visible TINYINT( 1 ) NOT NULL DEFAULT '1',
public_perms TEXT NOT NULL ,
badge_perms TEXT NOT NULL ,
data TEXT NOT NULL ,
PRIMARY KEY ( id )
)ENGINE=MYISAMAUTO_INCREMENT=11DEFAULTCHARSET=latin1;



MySQL said:


#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'desc varchar(255) NOT NULL,
descno varchar(255) NOT NULL,
longdesc text NOT ' at line 4
 

Brogan

XenForo moderator
Staff member
#7
Depending on the size of the database, phpMyAdmin may not be suitable.
I would recommend using SSH to dump and restore.
 

Linkzy

Active member
#8
Depending on the size of the database, phpMyAdmin may not be suitable.
I would recommend using SSH to dump and restore.
This is confusing and messed up I'm new to this nevermind ill start my forum fresh! My IPB forum wasn't that big the database and stuff... it only had 7 users and 200 posts like that i need them.