1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 Invalid prefix importing VBgallery

Discussion in 'Media Gallery Support' started by Steff, Dec 12, 2015.

  1. Steff

    Steff Member

    Hi guys I'm trying to import my Vbgallery 3.2 into media gallery. I've chosen import vbgallery but after filling out the database details I get a prefix error. The prefix is pp_ I've checked in the database but I think this prefix was set when I had Photopost many years ago. I migrated to VBgallery because it integrated better. So in all intence and purposes this is VB gallery and has been run that way since 2009.
    In desperation I did try the Photopost import and although the importer said the deytails were right only 4 categories out of the several hundred were imported. None of the 28,000 images or coments were imported either.
    What have I don wrong?
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    What are some of the actual table names and what did you enter as a prefix?
     
  3. Steff

    Steff Member

    Hi thanks for the reply. I used the prefix pp_
    Here's a screenshot of the database.
    Thanks for the reply I really appreciate the help :)[​IMG]
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    That is indeed your PhotoPost Pro database. Nearly nine of those tables have similar names in VBGallery.

    IIRC the VBGallery database is just a load of tables in your normal VB forum database.

    So, go back to using the VBGallery version of the importer and specify your VB database details. The prefix will be your VB database prefix if you had one.
     
  5. Steff

    Steff Member

    Yes the only prefix I have in the database is pp_ and when I try and use the VBgallery importer with that prefix it says it is incorrect.
    there are no other prefix in the database other than Xenforo and Vbulletin.
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    You need to point the importer at your vBulletin forum database, with whatever prefix you use for your vBulletin install.
     
    Steff likes this.
  7. Steff

    Steff Member

    I would like to thank you Chris D for you advice. I used the prefix VB_ and the script started to populate the gallery. I'm in to the seventh hour at the moment and am halfway through the comments I think.
    Thank you so much for your support and professionalism. I'm very excited about being part of a community once again :)
     
    Chris D likes this.

Share This Page