1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Reproduce "Invalid password" message, but still get logged in

Discussion in 'Resolved Bug Reports' started by x_Stricken_x, Jul 10, 2013.

  1. x_Stricken_x

    x_Stricken_x Active Member

    As the title says, when I login I get the "incorrect password" message - but I still get logged in successfully. I'll attach a screenshot if need be, but it's pretty self explanatory.
     
  2. Adam Howard

    Adam Howard Well-Known Member

    Just to clarify...

    Did you actually type in the right password when you got this message?
    Or did you type in the wrong password, get this message, but was still logged in?

    What version of XenForo are you using and also what web browser and OS (operating system)?
     
  3. x_Stricken_x

    x_Stricken_x Active Member

    The password was correct, the version of XenForo was whatever is running on these forums (1.2 beta 5 iirc). OS is iOS 6 on iPhone 5, browser is Google Chrome. Also, the error happened on these forums.
     
    Adam Howard likes this.
  4. x_Stricken_x

    x_Stricken_x Active Member

    Also, I will note that if I'm on a thread while signed out and then sign it, the error doesn't appear to show (that I've noticed thus far). I'll try a few more times and then note when it happens to possibly help pinpoint what/where the issue is.
     
    Adam Howard likes this.
  5. Hornstar

    Hornstar Well-Known Member

    Do you use your username or email address when logging in?

    I just tried logging in twice with both username and email on here on my iPhone 6 iOS 6.1.4 in both chrome and safari and all was fine.
     
    Last edited: Jul 10, 2013
  6. x_Stricken_x

    x_Stricken_x Active Member

    I use my username
     
  7. Kier

    Kier XenForo Developer Staff Member

    I'm afraid I'm struggling to reproduce this at all... can you provide any more details, or steps to reproduce the behaviour?
     
    Adam Howard likes this.
  8. x_Stricken_x

    x_Stricken_x Active Member

    I've been trying to reproduce it for a couple of days now, but I can't seem to figure out what it is. I also can't think of any details that would be relevant aside from maybe the fact that I have my Facebook linked to my account? I don't know if that would affect it
     
  9. Mike

    Mike XenForo Developer Staff Member

    Perhaps you got logged in via your FB integration after typoing the password? (You should've seen a redirect though.)
     
  10. x_Stricken_x

    x_Stricken_x Active Member

    Unless the code initialized the Facebook login, I don't see it being that. All I did was click the login button (my credentials were saved/filled in). Also, even if it did login through Facebook, wouldn't/shouldn't it have not shown an incorrect password anyways as there technically isn't one?
     
  11. Mike

    Mike XenForo Developer Staff Member

    The code does initialize the FB login automatically if it detects that you're logged into FB but not XF.

    Technically, there isn't a password so if you try to enter one, you're entering an incorrect password. (That said, it's possible to have a FB-associated login and a password.)
     
  12. x_Stricken_x

    x_Stricken_x Active Member

    My apologies, I didn't know how that aspect of it worked. Well, it should be safe to leave this as "cannot reproduce" for now as I've yet to reproduce it again. Thanks for the replies, @Mike
     
  13. wickedstangs

    wickedstangs Well-Known Member

    Not sure if this is the same thing, But this is happening on my forum.

    errorlogin.JPG
     
  14. x_Stricken_x

    x_Stricken_x Active Member

    I'm not sure if it is the same thing, but it's not the same thing I was talking about. Basically, I can login successfully, but it shows the "invalid password" page instead of whatever page I'm supposed to go to (even though my login was successful.
     
  15. Motobaka

    Motobaka Active Member

    This has been reported on our forum. I believe it has to do with the Facebook session. Some also say they get logged out when clicking any link on the forum while using Facebook login. Any idea of what that might be?
     
  16. x_Stricken_x

    x_Stricken_x Active Member

    I personally haven't had that specific issue
     

Share This Page