• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Internal Server Error

Ryan Kent

Well-known member
#1
I ftp'd all my RC3 files from the upload folder to my XF install folder (community). When complete I went to http://terapvp.com/community/install/ and received the following message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@terapvp.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


I assume this means the FTP process needs to be repeated?
 

Brogan

XenForo moderator
Staff member
#2
Can you enable debug mode and try again?
The error message may prove more useful.

Add the following line to your /library/config.php file: $config['debug'] = true;

Ensure you remove it after getting the information.

Also, is there anything in the Apache error log?
 

Brogan

XenForo moderator
Staff member
#8
Hmmm, well I don't think it will help but you could try uploading the upgrade package files once again and see if anything changes when you run the upgrade again.

Make sure you remove the debug entry from the config.php file.
 

Ryan Kent

Well-known member
#10
appears the result after a second upload is the same. What's the next best step? Restore the old forums then try again?

I am noticing random "Connection Timed Out. File Transferred Failed." errors. I am using FileZilla for the ftp. I scrolled up as far as I could to find some fails, but it seems the data spools off the top and is gone. I tried manually transferring some of the failed files and they uploaded ok.
 

Brogan

XenForo moderator
Staff member
#11
Restoring the old files won't help in this situation.

It looks like some debugging might be required and the man for that is Mike.
Unfortunately he won't be around until tomorrow.

I'll let Kier know though.
 

Ryan Kent

Well-known member
#17
what I see a lot of is the below. There are a lot more lines of similar code.

[Tue Feb 22 20:25:27 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/404.shtml
[Tue Feb 22 20:25:27 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/favicon.ico
[Tue Feb 22 20:25:26 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/500.shtml, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:25:26 2011] [error] [client 78.105.43.233] SoftException in Application.cpp:601: Directory "/home/terapvpc/public_html/community/install" is writeable by group, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:25:11 2011] [error] [client 86.28.168.180] File does not exist: /home/terapvpc/public_html/404.shtml
[Tue Feb 22 20:25:11 2011] [error] [client 86.28.168.180] File does not exist: /home/terapvpc/public_html/favicon.ico
[Tue Feb 22 20:25:10 2011] [error] [client 86.28.168.180] File does not exist: /home/terapvpc/public_html/500.shtml, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:25:10 2011] [error] [client 86.28.168.180] SoftException in Application.cpp:601: Directory "/home/terapvpc/public_html/community/install" is writeable by group, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:24:23 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/404.shtml
[Tue Feb 22 20:24:23 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/favicon.ico
[Tue Feb 22 20:24:22 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/404.shtml
[Tue Feb 22 20:24:22 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/favicon.ico
[Tue Feb 22 20:24:22 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/500.shtml, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:24:22 2011] [error] [client 78.105.43.233] SoftException in Application.cpp:601: Directory "/home/terapvpc/public_html/community/install" is writeable by group, referer: http://xenforo.com/community/threads/internal-server-error.12655/
[Tue Feb 22 20:24:13 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/404.shtml
[Tue Feb 22 20:24:13 2011] [error] [client 78.105.43.233] File does not exist: /home/terapvpc/public_html/favicon.ico
[Tue Feb 22 20:23:34 2011] [error] [client 98.100.160.88] File does not exist: /home/terapvpc/public_html/500.shtml
 

Ryan Kent

Well-known member
#19
:( it was 755 and I changed it to 777...argh! ok, will do.

My error. I changed an extra folder (install) to 777. Corrected. Install process begun.
 

rEd86

Active member
#20
I am noticing random "Connection Timed Out. File Transferred Failed." errors. I am using FileZilla for the ftp. I scrolled up as far as I could to find some fails, but it seems the data spools off the top and is gone. I tried manually transferring some of the failed files and they uploaded ok.
It sounds like you are not getting all the new files uploaded to your site.

What version of FileZilla are you using? The latest versions actually show Queued files, Failed Transfers and Successful transfers in tabs along the bottom of the window. (Under the "View" menu, make sure "Transfer Queue" is checked)

FileZillaQueues.gif

Try uploading again and wait for all the queued files to transfer. If you see failed files in the "Failed transfers" tab, you can view what didn't transfer and right-click on the list to "Reset and requeue all" to reattempt to upload the failed files. When they are queued (showing up in the Queued files tab and not the Failed Transfers tab) you select the "Transfer->Process Queue" menu item. Keep doing so until there are no files that have failed to upload.

Good luck!

--Ed