• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Intermittent Akismet Connection Errors

The Sandman

Well-known member
#1
Started getting occasion server error messages about two weeks ago relating to Akismet - anyone else getting these?

Code:
Error Info
Zend_Http_Client_Adapter_Exception: Akismet HTTP error: Unable to Connect to tcp://0db426a9d1cf.rest.akismet.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known - library/Zend/Http/Client/Adapter/Socket.php:235
Generated By: TAZ_user, Jun 27, 2015
Stack Trace
#0 /srv/www/theadminzone.com/public_html/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('0db426a9d1cf.re...', '80', false)
#1 /srv/www/theadminzone.com/public_html/library/Zend/Service/Akismet.php(248): Zend_Http_Client->request()
#2 /srv/www/theadminzone.com/public_html/library/Zend/Service/Akismet.php(295): Zend_Service_Akismet->_post('0db426a9d1cf.re...', '/1.1/comment-ch...', Array)
#3 /srv/www/theadminzone.com/public_html/library/Zend/Service/Akismet.php(326): Zend_Service_Akismet->_makeApiCall('/1.1/comment-ch...', Array)
#4 /srv/www/theadminzone.com/public_html/library/XenForo/Model/SpamPrevention.php(436): Zend_Service_Akismet->isSpam(Array)
#5 /srv/www/theadminzone.com/public_html/library/XenForo/Model/SpamPrevention.php(403): XenForo_Model_SpamPrevention->_checkAkismet('How to move sid...', Array, Object(Zend_Controller_Request_Http))
#6 /srv/www/theadminzone.com/public_html/library/XenForo/Model/SpamPrevention.php(389): XenForo_Model_SpamPrevention->_allowMessage('How to move sid...', Array, Object(Zend_Controller_Request_Http))
#7 /srv/www/theadminzone.com/public_html/library/XenForo/ControllerPublic/Forum.php(720): XenForo_Model_SpamPrevention->checkMessageSpam('How to move sid...', Array, Object(Zend_Controller_Request_Http))
#8 /srv/www/theadminzone.com/public_html/library/Waindigo/EditPostDate/Extend/XenForo/ControllerPublic/Forum.php(33): XenForo_ControllerPublic_Forum->actionAddThread()
#9 /srv/www/theadminzone.com/public_html/library/AnonymousPosting/ControllerPublic/Forum.php(13): Waindigo_EditPostDate_Extend_XenForo_ControllerPublic_Forum->actionAddThread()
#10 /srv/www/theadminzone.com/public_html/library/ModEss/ControllerPublic/Forum.php(146): AnonymousPosting_ControllerPublic_Forum->actionAddThread()
#11 /srv/www/theadminzone.com/public_html/library/XenMods/MultiPrefix/ControllerPublic/Forum.php(16): ModEss_ControllerPublic_Forum->actionAddThread()
#12 /srv/www/theadminzone.com/public_html/library/LiamW/PostMacros/Extend/ControllerPublic/Forum.php(23): XenMods_MultiPrefix_ControllerPublic_Forum->actionAddThread()
#13 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(347): LiamW_PostMacros_Extend_ControllerPublic_Forum->actionAddThread()
#14 /srv/www/theadminzone.com/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#15 /srv/www/theadminzone.com/public_html/index.php(13): XenForo_FrontController->run()
#16 {main}
Request State
array(3) {
  ["url"] => string(54) "https://theadminzone.com/forums/xenforo.314/add-thread"
  ["_GET"] => array(1) {
    ["/forums/xenforo_314/add-thread"] => string(0) ""
  }
  ["_POST"] => array(10) {
    ["title"] => string(53) "How to move sidebars to the bottom like in vbulletin?"
    ["message_html"] => string(549) "<p>The result I want to achieve is like this:</p><p><br></p><p>http://www.maxicep.com/forum/<br></p><p><br></p><p>scroll to the bottom to check how user statistics are shown as if it's vbulletin.</p><p><br></p><p>I tried searching and using some addons, turns out most are outdated and didn't work with xf 1.4</p><p><br></p><p>As far as I know it involves editing forum_lists. I don't know what to edit to achieve the same result as above.</p><p><br></p><p>Any help is appreciated, note that I'm using xenDark theme. Thanks</p><p><br></p><p><br></p>"
    ["_xfRelativeResolver"] => string(57) "https://theadminzone.com/forums/xenforo.314/create-thread"
    ["attachment_hash"] => string(32) "5e25d7f05c0a958740a2afbaff209d41"
    ["watch_thread_state"] => string(1) "1"
    ["poll"] => array(5) {
      ["question"] => string(0) ""
      ["responses"] => array(2) {
        [0] => string(0) ""
        [1] => string(0) ""
      }
      ["max_votes_type"] => string(6) "single"
      ["change_vote"] => string(1) "1"
      ["view_results_unvoted"] => string(1) "1"
    }
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(33) "/forums/xenforo.314/create-thread"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}