1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Installation problem

Discussion in 'Installation, Upgrade, and Import Support' started by Manoj_Kumar, Dec 17, 2013.

  1. Manoj_Kumar

    Manoj_Kumar Guest

    I have checked with the configuration that I have entered in config.php, Everything is fine but still I am getting:


    An unexpected database error occurred. Please try again later.
    <!-- Access denied for user 'sportspoint_xf'@'localhost' (using password: YES) -->

    Did an upload for database connectivity check here, it work fine though: http://sportspoint.net/community/checkdb.php

    What am I missing here? I have done numerous Xenforo installations before, never have I found this issue.
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Your database user and password is incorrect.
  3. Manoj_Kumar

    Manoj_Kumar Guest

  4. Manoj_Kumar

    Manoj_Kumar Guest

    Even the Xenforo installer script validates it. User privileges are set to all.

    Configuration Builder
    The configuration information you entered is valid.

    But when I click 'Continue with installation':

    The following error occurred while connecting to the database:

    Access denied for user 'sportspoint_xf'@'localhost' (using password: YES)
    This indicates that your configuration information is not correct. Please check the values you have entered. If you are unsure what values are correct or how to proceed, please contact your host for help. These values are specific to your server.
  5. Mike

    Mike XenForo Developer Staff Member

    This likely means that the data is correct, but you have no(?) privileges on the database itself (like SELECT, UPDATE, etc). You should have full privileges.
  6. Manoj_Kumar

    Manoj_Kumar Guest


    Permissions are set to all. I have WordPress on main domain and it works without any problem.
  7. Mike

    Mike XenForo Developer Staff Member

    Can you show us the (full) output from this query?
    SHOW GRANTS FOR sportspoint_xf@localhost;
    Note that there's an encoded password in the output -- you can remove that part.

    Also, just to confirm you have entered "localhost" as the host in config.php right?
  8. Manoj_Kumar

    Manoj_Kumar Guest

    GRANT ALL PRIVILEGES ON *.* TO 'sportspoint_xf'@'localhost' IDENTIFIED BY PASSWORD 'Removed' WITH GRANT OPTION GRANT ALL PRIVILEGES ON `sportspoint\_xf`.* TO 'sportspoint_xf'@'localhost' WITH GRANT OPTION
    Yes, It's localhost server. Should be a simple issue, but can't able to figure it out. Even I have edited file permissions recursively before to address file read/write problem although it is irrelevant here.
  9. Mike

    Mike XenForo Developer Staff Member

    I definitely don't see any issue there.

    Are you perhaps running 2 MySQL servers with different default sockets between the mysql and mysqli extensions? That's really the only thing I can think of at this point.
  10. Manoj_Kumar

    Manoj_Kumar Guest

    Here is my PHPmyAdmin Screenshot. Both WordPress and Xenforo are in the same server. Is there anything to do with the Table prefix? Because I used wp_ for WordPress installation.

  11. Manoj_Kumar

    Manoj_Kumar Guest

    Fixed. Looks like restarting the MySQL server did the trick.

Share This Page