1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.0 Importing or new style database error.

Discussion in 'Troubleshooting and Problems' started by TazDevilLooney, Oct 26, 2011.

  1. TazDevilLooney

    TazDevilLooney Active Member

    Hi there, when i try to create or import any style i get this message. There is nothing in any server logs or in Xenforo's logs to give any ideas to why. Has anyone seen this before?

    An unexpected database error occurred. Please try again later.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    View the source code of the error page. There should be a more specific error message.
     
  3. TazDevilLooney

    TazDevilLooney Active Member

    Umm only happens on the styles upload. Sites running fine.

    I can also edit the existing styles and they save ok. Look like it's just the style importer.

    I also have a VB site on the same server and that creates a style just fine. How odd, any advice.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's a server problem. The connection to the database is "going away" for some reason. You may need to adjust your MySQL configuration. Here are some possibilities:

    wait_timeout
    max_allowed_packet


    If you don't manage your own server then you need to ask your host or server person to do this.
     
  5. TazDevilLooney

    TazDevilLooney Active Member

    I decided to reinstall the hole server including operating system. Installed a fresh copy of Apache and copied the website files and database over to the new install.
    Same problem.

    I then removed all addons.
    Same problem.

    I then overwrite the files with a fresh copy from Xenforo.
    Same problem.

    I then removed one of the styles and to my surprise it would let me create a new style.
    Went to create a 2nd one and database error again.

    If i remove one it allows me to install one but no more than one. Any ideas?
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Did you increase the values of those MySQL settings?

    wait_timeout
    max_allowed_packet


    That usually fixes this error.
     
  7. TazDevilLooney

    TazDevilLooney Active Member

    Not yet, i'll have a go and get back to you. (y)
     
  8. TazDevilLooney

    TazDevilLooney Active Member

    max_allowed_packet

    I have increased it from 1mb -> 5mb and seems to of corrected the problem.

    I'll do some more test's though. (y)
     
  9. TazDevilLooney

    TazDevilLooney Active Member

    The max_allowed_packet did fix the problem Jake. Thanks for your help (y)
     

Share This Page