1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Importing language gives me a Forbidden

Discussion in 'Troubleshooting and Problems' started by polle, May 14, 2012.

  1. polle

    polle Active Member

    Hello.

    I just did a clean install and I have a problem. When I import a language xml file I get this:

    "Forbidden
    You don't have permission to access /forum/admin.php on this server."

    How can I fix this ?

    Thanks.
     
  2. polle

    polle Active Member

    Adding more here, I don't kow if the next problem has anything to do with my problem mentioned above.

    After health check I get this: "library/XenForo/Model/Permission.php File does not contain expected contents.". I downloaded today and installed today. I re upload that file from the zip and the same.

    Thanks.
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That file should be fixed. Maybe your zip file is corrupt. Try re-downloading the zip file and then uploading those new files.

    The 403 forbidden error is usually a permission problem on the server. Re-uploading the files may fix that. Depending on your server configuration, directories are usually 755 and files are 644. data and internal_data should be either 777 or 755, again depending on your server configuration.
     
  4. polle

    polle Active Member

    1- Well, I just downloaded the zip again, re upload and the same.
    2- I have the permissions like that, what other files needs permissions ?

    What to do in each case ?

    Thanks.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  6. polle

    polle Active Member

    Ok, that is fixed now, thank you. Interesting that just FileZilla fixed that and no other FTP clients can.

    Now with the main problem. When I import a language xml file I get this:

    "Forbidden
    You don't have permission to access /forum/admin.php on this server."

    How can I fix this ?

    Thanks.
     
  7. ragtek

    ragtek Guest

    have you "mod_security" installed?
    Check the apache error log
     
  8. polle

    polle Active Member

    Hi ragtek, yes I do.

    This is what I get in the log.

    Code:
    [Wed May 16 03:23:59 2012] [error] [client 80.xx.xx.xx] ModSecurity: Access denied with code 403 (phase 2). Match of "eq 0" against "MULTIPART_UNMATCHED_BOUNDARY" required. [file "/etc/httpd/conf.d/mod_security.conf"] [line "86"] [msg "Multipart parser detected a possible unmatched boundary."] [hostname "site.com"] [uri "/forum/admin.php"] [unique_id "T7111OAsksh7ndoaJGodnsAF"]
    Any idea what I need to do ?

    I have another XF instalation for other domain in the same server with no problems at all.

    Thanks.
     
  9. ragtek

    ragtek Guest

  10. polle

    polle Active Member

    The only solution is to disable mod_security boundary matching. After that it worked.

    Thanks.
     

Share This Page