XF 2.2 Made board inactive but no message is displayed


New member
I have aproblem. I have made my board inactive but it seem noone can read any message I left, They get this:


You don't have permission to access this resource.

Is there a solution?
Have you tried the Analyse permissions tool? It’s a great way to find out where your permissions are going wrong.

I am a bit confused as you say message, whereas the notice refers to a Resource.
If it's a generic white Apache/nginx error page, it sounds like something on the server is configured to show a server error page when a certain response header is sent, and it's showing that error page at server level.
If you inactivated your forum then users will see this message.

"Sorry, we're currently unavailable. Please check back later." They won't be able to see any forums.
It's nothing to do with XenForo or permissions, it's a server misconfiguration. Just going to index.php throws a 404, and no index.php throws a 403. You'll need to ask your host about it.
I do get this when the board is set to inactive

Test URL unfurling​

This tool helps diagnose errors relating to the URL unfurl system including which metadata can be fetched.

The following error occurred while fetching metadata from URL https://mylovedoll.uk/index.php?members/
Could not fetch metadata from URL with error: Response returned a non-successful status code: 503

That may be correct?

when it active you get a nice message.
While i;m doing thst have any of you aby experience with this..

OK I have been trying for a few days to import MYBB data into a new zenfoto site, but a many of the posts are just showing something like [Empty Message]. There doesn't seem to be a reason for it. At first i thought it was smilies that were doing it, but it happens on post without smiles.

Does anyone have any ideas?
Well not fix, patched as most members wont have the address with the WWW in it.

I'll try a support ticket
Surely you just need to redirect www

I think this worked for me

from no www to www

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_HOST} ^domain\.com [NC]
RewriteRule ^(.*)$ http://www.domain.com/$1 [L,R=301]

from www to no www

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_HOST} ^www\.domain\.com [NC]
RewriteRule ^(.*)$ http://domain.com/$1 [L,R=301]

It all depends on what you want the address to be. I prefer no www as it's simpler.
I got it fixed. Support just told me to turn canonical on, that solved most of the problem as it forces users to use the WWW in the url, and then its fine. When board is active the WWW isn't problem anyway.
Top Bottom