1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Importing from vB 4.X

Discussion in 'Media Gallery Support' started by BoostN, May 27, 2015.

  1. BoostN

    BoostN Active Member

    I just purchased XFMG to import albums from my old vB installation. I converted from vB 4.X to XF about 6 months ago. However, I'm just now getting a chance to import the albums.

    Instead of installing my entire vb data on my XF server, I copied the "albums" folder from vb. It has a directory structure like this:

    0
    1
    2 -- Screenshot below inside the structure
    -- vbAlbumStructure.JPG
    I'm not sure why I have .picture files. That might be a problem?

    Now for the import, I placed the root album directory and used the archived import log as prompted by the importer.

    After my first test I get this:
    Albums: Imported 863 items. (6.75 seconds)
    Media: Imported 0 items. (7 minutes 51.19 seconds)

    I can see albums, usernames and the album descriptions, but no actual pictures in the albums..

    Any ideas?
     
  2. Mike

    Mike XenForo Developer Staff Member

    The 1234.picture is the expected filename, but that is specific to the vB 3.x importer. You mentioned importing from 4.x, which pulls the picture from the general attachments system data.
     
  3. BoostN

    BoostN Active Member

    I'm coming from a vB 4.x installation ( it was a 3.x at one point as well) . I'm assuming the file directory "albums" is wrong and I should point the file path location to attachments? How does the system know and attachment is actually part of an album?
     
  4. Mike

    Mike XenForo Developer Staff Member

    There is data in the database that indicates what files are needed. But yes, you need to point it to the (old) attachments directory.
     
    jeffwidman likes this.

Share This Page