XF 2.2 Importing from SMF 2.1 - open_basedir problem

voom

Member
I tried to import from SMF 2.1.2, but always run into open_basedir errors.

Originally I installed XF into a different "webspace" in Plesk, than where SMF is. So I thought that might be the reason. But then I reinstalled it under the same webspace and the errors were identical. Now it is back in the other webspace.

I thought I'd give up on the import, but after reading that SMF 2.1 should work, I want to try to solve the open_basedir issue.

Any ideas?
 

voom

Member
I tried that, using some helpfiles. I could not quite figure it out. (This is a cloudserver with Linux root and Plesk, so I am more or less on my own with this.)

When I tried, the error showed the changes I made, including the base folder of that SMF installation, but still said it was not allowed
 

voom

Member
Thank you, that was kind of counter-intuitive.

But now I get the next error:

Code:
ErrorException: [E_WARNING] Undefined array key "location" in src/addons/XFI/Import/Importer/SMF.php at line 686
XF::handlePhpError() in src/addons/XFI/Import/Importer/SMF.php at line 686
XFI\Import\Importer\SMF->setupImportUser() in src/addons/XFI/Import/Importer/SMF.php at line 525
XFI\Import\Importer\SMF->stepUsers() in src/XF/Import/Runner.php at line 244
XF\Import\Runner->runStep() in src/XF/Import/Runner.php at line 61
XF\Import\Runner->run() in src/XF/Admin/Controller/Import.php at line 234
XF\Admin\Controller\Import->actionRun() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2352
XF\App->run() in src/XF.php at line 524
XF::runApp() in admin.php at line 13
 

Arantor

Active member
That looks like the importer hasn't been updated for 2.1 since that looks to me like it's looking for the location field that used to be a hard-coded profile field but as of 2.1 isn't any more.
 

voom

Member
People reported, that they could successfully import from SMF 2.1.

I tried to import without custom profile fields, but the error remains. Is there anything I can do, to fix it myself? I need not import the profile fields. Priority are Posts.

Some stuff was imported, before it broke off. I got user groups and profile fields, including "Location".
 
Last edited:
Top