1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Importing Custom Style

Discussion in 'Resolved Bug Reports' started by dwdmadmac, Sep 26, 2015.

  1. dwdmadmac

    dwdmadmac Active Member

    When I tried to import a custom style I was working on, I received this error.

    Code:
    The following error occurred:
    
    An exception occurred: conversation_message - Line 10: <xf:if> tags can only be used where full statements are allowed. in /home/dwd/Subdomains/forums/library/XenForo/Template/Compiler.php on line 991
    
    XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Tag/If.php at line 35
    XenForo_Template_Compiler_Tag_If->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 456
    XenForo_Template_Compiler->compileAndCombineSegments() in XenForo/Template/Compiler/Tag/Avatar.php at line 50
    XenForo_Template_Compiler_Tag_Avatar->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Hook.php at line 37
    XenForo_Template_Compiler_Tag_Hook->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
    XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1611
    XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1479
    XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1328
    XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1267
    XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
    XenForo_Deferred_Template->execute() in XenForo/Model/Deferred.php at line 295
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
    XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
    XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/Json.php at line 147
    XenForo_ViewRenderer_Json::_addDefaultParams() in XenForo/ViewRenderer/Json.php at line 185
    XenForo_ViewRenderer_Json::jsonEncodeForOutput() in XenForo/ViewRenderer/Json.php at line 61
    XenForo_ViewRenderer_Json->renderError() in XenForo/FrontController.php at line 589
    XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    XenForo_FrontController->run() in /****/.../forums/admin.php at line 13
    I looked inside the "conversation_message" but line 10 does not show anything relative to the given error.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Do you have any add-ons which affect the conversation_message template using Template Modifications? Check Admin CP > Appearance > Template Modifications, look down the list for conversation_message. Disable any TMs you find against that template, and then try the process again.
     
  3. dwdmadmac

    dwdmadmac Active Member

    Thank you @Chris D, I didn't even think about looking into add-ons. I had New User Conversation v2.0 installed with XF 1.5, I removed this and everything imported fine.
     
    Last edited: Sep 26, 2015
  4. dwdmadmac

    dwdmadmac Active Member

    Okay never mind, anything I do that has to do with processing templates, I get this error.

    Code:
    An exception occurred: conversation_message - Line 10: <xf:if> tags can only be used where full statements are allowed. in /home/dwd/Subdomains/forums/library/XenForo/Template/Compiler.php on line 991
    
    XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Tag/If.php at line 35
    XenForo_Template_Compiler_Tag_If->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 456
    XenForo_Template_Compiler->compileAndCombineSegments() in XenForo/Template/Compiler/Tag/Avatar.php at line 50
    XenForo_Template_Compiler_Tag_Avatar->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Hook.php at line 37
    XenForo_Template_Compiler_Tag_Hook->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
    XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Include.php at line 113
    XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
    XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
    XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
    XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
    XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1611
    XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1479
    XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1328
    XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1267
    XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
    XenForo_Deferred_Template->execute() in XenForo/Model/Deferred.php at line 295
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
    XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
    XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 130
    XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 633
    XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    XenForo_FrontController->run() in /home/dwd/Subdomains/forums/admin.php at line 13
    I even tried to rebuild the master still get this error.
     
    Last edited: Sep 26, 2015
  5. Mike

    Mike XenForo Developer Staff Member

    If the style imported (is showing in the style list), please delete it. It seems that your style may have invalid code in it. (Imported styles are generally assumed to be valid.)

    If it doesn't show up, please disable all add-ons and try the master data rebuild. If it goes through, it's likely an add-on with an invalid template modification.
     
  6. dwdmadmac

    dwdmadmac Active Member

    Nothing was listed there that was against conversation_message. I tried to upgrade to XF 1.5.1 and now I am stuck on upgrading. Once it gets to processing templates it errors out with the above error. I tried to emptying a few tables in the database hoping maybe it can get past that process (templates), but that didn't seem to help either.

    Database Tables I empty:
    • xf_conversation_master
    • xf_conversation_user
    • xf_conversation_recipient
    • xf_conversation_message
    • xf_tag
    • xf_tag_content
    • xf_tag_result_cache
     
  7. dwdmadmac

    dwdmadmac Active Member

    I posted my comment before I seen this, I will try this now.
     
  8. dwdmadmac

    dwdmadmac Active Member

    Okay fix the problem, was an issue with my custom style. Thank you.
     

Share This Page