1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Importing began - wow

Discussion in 'General XenForo Discussion and Feedback' started by LPH, Dec 29, 2011.

  1. LPH

    LPH Well-Known Member

    I am absolutely impressed by everything that has happened. Installation was a breeze. Installing XenDynamic was a snap. Importing started 1/2 hour ago and 2% of the threads are already converted.

    After conversion, I'll move the forums into their new server and move the domain name. Things are right on schedule for a midnight December 31 party :)

    I am still trying to figure out how to match Adsense displaying from vb4 to XF. I've read the conditionals but maybe there is a good how to written already. Ah the joy !

    Exciting to be able to rebuild this forum after fussing the past two years or so with vb4 (not knocking it - just rough edges).

    Thanks to everyone who has helped so far.

    PS. New domain for these forums is hyperdebates. We are building this to be part of the tuxreportsnetwork.com ... Eh. Sorry about the cheap link there. Just excited :)
  2. LPH

    LPH Well-Known Member

    Oops sorry about putting that post in the wrong forum :(
  3. LPH

    LPH Well-Known Member

    OK ! It looks like another 3.5 hours and the conversion will be done. I still have 16.5K files uploading for the blogs being moved to the new location. The conversion is moving fairly quickly and I'll move the database after the conversion is done.

    Attached Files:

  4. Vincent

    Vincent Well-Known Member

    Why the picture of the girl and dog? :p
  5. kyrgyz

    kyrgyz Well-Known Member

    What is XenDynamic?
  6. Digital Doctor

    Digital Doctor Well-Known Member

  7. LPH

    LPH Well-Known Member

    Oh - I was testing. Sorry. I am not able to upload pictures using the iPad but see things are much different using IE 9 on a desktop.
    Vincent likes this.
  8. Digital Doctor

    Digital Doctor Well-Known Member

  9. Vincent

    Vincent Well-Known Member

    Don't worry, it's the abbreviation of Ireland, he's just mixing things up. It's not like a company would be stupid enough to create a browser with a name like Internet Explorer or something..
  10. LPH

    LPH Well-Known Member

    Import is done. :D

    I've asked the hosting company to move the new database to the correct server so that the forums become part of the network. Hopefully they'll say yes because the database is over 3 GB.

    Sadly, I forgot to take a screenshot of the times for conversions. Let's just say - fast. I started uploading the script at 8:30 and finished the conversion by 2:30. The rebuilding of caching kept failing but I'll rebuild when the database is transferred or copied to the new server.

    I'm now uploading the xml files for the 16 wordpress sites on the "old" network being merged into tuxreportsnetwork.com.

    Phew - good 2 days into this project - and only a few more days to go :barefoot:

    PS - about IE - I only used it to see if the experience is different than the iPad. Besides, my sister works for Microsoft and not Google. :p
    Digital Doctor likes this.
  11. Edrondol

    Edrondol Well-Known Member

    You're gonna love it.
    Fuhrmann likes this.
  12. Claudio

    Claudio Well-Known Member

    why donĀ“t you try the import on localhost?
  13. digitalpoint

    digitalpoint Well-Known Member

    Not to take anything away from the process (because the import is quite nice), but I think I would have a hard time being excited about 2% being done in 30 minutes. :) Would work out to roughly 24 hours to import threads/posts... Looks like you have about 2M posts... what if you had like 10M? 5 days of downtime just for the posts to be imported?

    Did you try the CLI importer?
    mrGTB likes this.
  14. LPH

    LPH Well-Known Member

    The import was not done locally because of the database size. Uploading and downloading 3GB would have taken too long.

    Actually importing was slower because I was entering information, double checking, etc. Working on an iPad is not easy (I'm traveling and not at a desktop). The import of all the threads took less than 4.5 hours. The hosting company then moved the database to the new server. sadly I didn't take a snapshot of the times.

    Final resting place: www.tuxreportsdebates.com

    Caution: We are making changes to the forum layouts as we add all the blogs together. It should be fun :)
  15. Carlos

    Carlos Well-Known Member

    I'm thinking that yer sister works in the Mountain View M$ building, no?
  16. LPH

    LPH Well-Known Member

    Seattle and is on the road most of the time.
  17. craigiri

    craigiri Well-Known Member

    Very neat - looks like the new forum is up, but was a problem when I clicked a the link on the right "Latest: Updated vBulletin Software"
    It takes me to an error page.
    But when I go into that node and click it, it's there. Probably a "base directory" problem of some sort.

    I am starting work on experimenting with moving a similar size db to XF - 1 million posts (1 gig data) and 7 gigs of attachments. Does the size of the total attachments affect the import greatly? Or is it mostly the actual mysql data.
    To make matters more complicated, I have to do a double import - that is, from an unsupported forum into a supported one and then into XF. This obviously is going to take some time!
  18. LPH

    LPH Well-Known Member

    Yes, even after rebuilding the cache this problem exists for imported threads. Any new thread does not have the issue.

    I'm also having terrible trouble with the WP-bridge. Network enabling the plugin causes one of the sites to just redirect to the forums. Oh joy ! :censored:
  19. craigiri

    craigiri Well-Known Member

    I'd have to think it's a setting or something - because a test import of my forum isn't doing that.....maybe the techs here can check the link and give you a hint.
  20. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page