MG 1.1 Import-problem: accents get lost?

Hi all,

I can't find a similar posting about this, so I hope I am not asking an old question.

When doing an import from Photopost VB I noticed that all titles with an accent simply loose that character. For instance Aragón becomes Aragn. Any way to avoid this? Even if it would simply just import it as Aragon would be better than simply delete the special character...

Thanks for any advice!


Chris D

XenForo developer
Staff member
The importer is designed to handle the conversion from the source character set to UTF-8.

What this likely suggests is that the "Force Character Set" option which is presented while configuring the importer was wrong.

Can you recall if you specified an option here and what it was for both the vBulletin database and the PhotoPost database?
Hi Chris,

Thanks for your swift reply. I did not choose any forced set as far as I remember. But then again: it's still a test-import, so no problem. I can do it again tomorrow morning.

In the import of Vbulletin I don't recall to have seen the same thing. So maybe there it was different.

What exactly do I type in the 'Force Character Set:' field in the import-tool??

Thanks in advance!


Chris D

XenForo developer
Staff member
This is a good question.

It depends on the collation used by PhotoPost.

For good measure I think if you specify windows-1252 for both character set fields, that might help. I think this is usually the default. However, you may be able to ascertain what setting has been set in both. I think you'll find this in the config file for PhotoPost as far as I can remember...