1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I'm trying to install add-ons but struggling, am I missing something?

Discussion in 'XenForo Questions and Support' started by JPMiddleton, Jul 30, 2012.

  1. JPMiddleton

    JPMiddleton New Member

    I've followed the instructions in the manual and uploaded the contents via FTP, then installed .xml to the admin cp... but it keeps saying error can't find file, no matter which add-on I try and upload.

    I know i'm doing something wrong I just don't know what!
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Most addons have a library folder you need to upload. That folder corresponds to the library folder on the server that already exists as part of XenForo. Make sure you upload whatever files are in there. Then you need to upload the XML file in the Admin CP. The easiest way is to use the browse button and select it on your computer.

    Screen shot 2012-07-30 at 6.44.07 AM.png
    JPMiddleton likes this.
  3. borbole

    borbole Well-Known Member

    Are you uploading the files in the right place maintaining the structure intact?
    JPMiddleton likes this.
  4. JPMiddleton

    JPMiddleton New Member

    Hello guys,

    Thanks for your replies.

    I've uploaded the 'library folder straight into the corresponding library folder and i'm still getting the same error.
  5. borbole

    borbole Well-Known Member

    What mod is it that you have trouble installing?
    JPMiddleton likes this.
  6. Chris D

    Chris D XenForo Developer Staff Member

    The library folder needs to be uploaded to the root of your XenForo installation (where there is already a library folder).

    The contents of the new library folder will then merge with the contents of the existing library folder.

    If it's easier to think about it this way: The contents of the downloaded library folder need to be put into the existing library folder.
    JPMiddleton likes this.
  7. JPMiddleton

    JPMiddleton New Member

    Having the same issue with different add-ons so I know it's my fault..
  8. JPMiddleton

    JPMiddleton New Member

    That's how i've been understanding it.... I'm sure i'm doing that, but I mustn't be... i'll check again.

    Thanks guys.
  9. Chris D

    Chris D XenForo Developer Staff Member

    You said that you've put the library folder in the library folder. That's not correct.

    You could take a screenshot of your directory structure if you like, that'll help us identify what's gone wrong.
    JPMiddleton likes this.
  10. JPMiddleton

    JPMiddleton New Member

    OK, here's a screen shot...

  11. JPMiddleton

    JPMiddleton New Member

    Finally got it guys, sorry! Thanks for your help folks.
    HenrikHansen and Chris D like this.
  12. Chris D

    Chris D XenForo Developer Staff Member

    EDIT: Glad you got it :)
    JPMiddleton likes this.
  13. Jungalist81

    Jungalist81 Member

    I too am having trouble with installing add-ons. I am trying to install the xenporta plugin. I downloaded it and unzipped it on my desktop. There is 2 folders in it: JP and Library. There is also a file named DONATIONS. From what I am understanding, this is what I have to do:

    1. I have to take the contents of whats inside of the library and place it in this directory: /www/library
    2. Next, I have to locate and remember where the file: addon-EWRporta is located (which is in /www/library/EWRporta/addon-EWRporta.xml)
    3. Finally, I have to goto my Admin CP and click on Add-on, click on install New Add-on.
    4. on the Install New Add-on page, I have to choose Install file from server and type: /www/library/EWRporta/addon-EWRporta.xml

    Please correct me if I am wrong.
    Question: what do I do with the rest of the contents that I have downloaded?
  14. Chris D

    Chris D XenForo Developer Staff Member

    You are correct.

    Except, the XML file path would be library/EWRporta/addon-EWRporta.xml

    That, or you could just browse for it on your computer (probably easier).

    EWRPorta includes a js, library and styles folder plus a file called donation_callback.php.

    All of these need to be uploaded to your www folder.

    No need to do them separately, just drag and drop them all into your www folder on your FTP client.
  15. Jungalist81

    Jungalist81 Member

    Okay thanks for the reassertion. I was able to successfully install xenporta.
    Chris D likes this.

Share This Page