1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Icons on forums issue

Discussion in 'Troubleshooting and Problems' started by Betclever, Dec 11, 2014.

  1. Betclever

    Betclever Active Member

    Hello,

    I use an addon "vinavb_customnodeicon" so I can change the icons on the homepage but when I replace the old ones with the new ones, it is not centered...

    Is there any possibility to fix it with CSS or something else?

    The problem is on all categories...

    Please find a screen shoot:

    [​IMG]

    Even if I change the size from 48 pixels to 64 or bigger, the size still the same...

    Thanks for your help,
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will have to ask for support in the add-on thread.
     
  3. Betclever

    Betclever Active Member

    In fact, this addon just add a button to change the icon but nothing else.

    No possibility to center these ones with CSS like the template extra.css?
     
  4. Amaury

    Amaury Well-Known Member

    As Brogan said, ask for support in the add-on thread.
     
  5. Betclever

    Betclever Active Member

    Thanks for the reply but apparently, this addon gives some problem with pictures which are too big so only tiny icons work...
    Is there any alternative via CSS or via a template like with "ID" cause I have for each category an ID which is available?

    THanks,
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    As instructed... if you want detail support for the add-on, post in the add-on thread. If it's the one I'm thinking of - the thing hasn't been updated in over a year and I don't think the author of it has been online here in at least that long. There were problems with it even when it was new. The EXTRA.css method is the most reliable to assign custom node icons.
     
  7. Betclever

    Betclever Active Member

    Ok but what shall I do then?
    No alternative a part this addon to change nodes?

    I saw a lot of forums with custom nodes so is there any possibility to change nodes via a template IDK?
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    EXTRA.css... and there are tons of posts on how to do it (I know that I've got at least 5 detailing what to do posted on the forum) as well as one or two resources.
    One recent post by me is at https://xenforo.com/community/threads/changing-forum-icons.66170/#post-863780.

    Using that method gives similar to this
    Screen Shot 2014-12-11 at 8.29.59 PM.png
     
  9. Betclever

    Betclever Active Member

    Thanks, it should help of course but there are tons of codes and I don't understand which one shall I put in my extra.css template??

    I have tried to paste these 2 codes into my extra.css sheet with ID 73 by ex. for my category but the icon disappear and it is blank...
    Can you tell me why?

    .node.node_2 .forumNodeInfo .nodeIcon, .node.node_2 .categoryForumNodeInfo .nodeIcon {
    background-image: url("images/nodes/node-sprite.png");
    background-position: 0px -88px;
    background-color: transparent;
    opacity: 0.4;
    }
    .node.node_2 .forumNodeInfo.unread .nodeIcon, .node.node_2 .categoryForumNodeInfo.unread .nodeIcon {
    background-image: url("images/nodes/node-sprite.png");
    background-position: 0px -88px;
    opacity: 1.0;
    background-color: transparent;
    }

    I also changed the image location like => styles-mytheme-... but same issue...

    Thanks for you help,
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    The above assumes you are using a sprite sheet. If you are not, then you need to use the other example.. with the path to the images changed appropriately.
     
  11. Betclever

    Betclever Active Member

    Ok,
    Here is the result:

    [​IMG]

    I have modified the second one so "blabla entre nous" and you can see on the screen a blue rectangle and the icon which is shifted... :(

    Please find the code I put into my extra.css template:

    .node.node_72 .forumNodeInfo .nodeIcon, .node.node_72 .categoryForumNodeInfo .nodeIcon {
    background-image: url("styles/flexile/flexile/bleu-dossier-farcies-icone-3996-48.png");
    background-position: 0px 0px;
    opacity: 0.4;
    }
    .node.node_72 .forumNodeInfo.unread .nodeIcon, .node.node_72 .categoryForumNodeInfo.unread .nodeIcon {
    background-image: url("styles/flexile/flexile/bleu-dossier-farcies-icone-3996-48.png");
    background-position: 0px 0px;
    }

    Is this normal cause I have the same issue with other icons and all icons are shifted even I have choose a tiny one...

    Thanks,
     
  12. Tracy Perry

    Tracy Perry Well-Known Member

    Part may be due to using flexile. Link to the forum?
     
  13. Betclever

    Betclever Active Member

  14. Tracy Perry

    Tracy Perry Well-Known Member

    You will need to co-ordinate so that you have that code in the EXTRA.css so that whomever helping you can look at it. It may even be necessary for them to have access to the ACP to check your EXTRA.css and some other settings in the Style Properties. From what I saw you are still using the default.
    Also, what size is the image you are trying to use. You need to use the same size as what is defined in your node icons settings in the ACP (which the image appears to be 48x48 pixels).
     
  15. Betclever

    Betclever Active Member

    Hello,

    Please find an exemple:

    [​IMG]

    Do you see the text by ex. "Premier League" the word "league" is masked and when I change a settings to move the icon to the right or what ever, the bar "last threads" in blue goes to the right...

    Please find my settings :

    [​IMG]

    If I change the pixels to 48x48, the bar "last threads" goes to the right too...
    The icons I'm using are 48x48.

    Thanks for your help,

    PS: It is in French so if you need, I can translate. :)
     
  16. Betclever

    Betclever Active Member

    UP please
     
  17. Tracy Perry

    Tracy Perry Well-Known Member

    Since you are using the Flexile style, I think you might get more help by posting in that style support thread.
     

Share This Page