1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 I need immediate support. I'm trying to move my forum directory to the homepage

Discussion in 'Troubleshooting and Problems' started by TheXboxCloud, Sep 1, 2015.

  1. TheXboxCloud

    TheXboxCloud Active Member


    I believe I've done it right. I moved the files directly to public_html and got rid of the other directory. Meaning the core files and folders are in public_html

    I then renamed the board url to (www.thexboxcloud.com).

    It showed the site but the site does not have any images and the style I was using does not show.

    Any help?
  2. drastic

    drastic Well-Known Member

    check your style properties and settings to make sure your filepath for the style is correct.

    your file paths may still be pointing to the old folder.
  3. rafass

    rafass Well-Known Member

    Your CSS for some reason have status 404:
    Screen shot 2015-09-01 at 3.37.45 PM.png
  4. Rob

    Rob Well-Known Member

    I'm getting the same issues as rafass - I can't imagine anything in xenforo is set wrongly and you'd be hard pushed to duplicate that error easily. I would hazard a guess this is some server related issue or a missing htaccess rule?
  5. TheXboxCloud

    TheXboxCloud Active Member

    I'm not sure what is causing the issue. Can anyone be more specific on what they believe the cause is?

    It was working just fine a little while ago when it was in a directory named /xenforo

    We had a vbulletin page up before I made the transfer but I deleted the files and it's database so I don't believe that could be causing the issue.

    If it is .htaccess what line do you think could cause this problem?

    I'm going to make a ticket with Xenforo support but please do give me an answer if you have it.
  6. Rob

    Rob Well-Known Member

    Could you post the content of the .htaccess file in your public_html directory? Are you sure the other folders have been removed?

    Have you or your host at any time edited your server's conf file?
  7. TheXboxCloud

    TheXboxCloud Active Member

    This is a copy of my .htaccess file

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 405 default
    ErrorDocument 406 default
    ErrorDocument 500 default
    ErrorDocument 501 default
    ErrorDocument 503 default
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    My vBulletin board worked fine on the homepage and my xenforo board also worked fine when it was in the directory /xenforo

    Also no one has edited that file. I just moved to a new host and everything was working great up until now.
  8. Rob

    Rob Well-Known Member

    Hmmm.... that all seems fine.

    Can you check your xenforo options and make sure the board urls are correct in all places. Also, check the @imagePath in your style properties.

    Hit the install url (/install) and rebuild the core master data - also can you run a file health check under the tools section of the admin area?
  9. Chris D

    Chris D XenForo Developer Staff Member

    The console errors suggest css.php is missing. Is it missing?

    If you check the Admin CP > Tools > File health check does that report any issues?

    If any files are missing download the current version of XF you are using from your customer area and re-upload the files from that.
  10. TheXboxCloud

    TheXboxCloud Active Member

    No file are missing though.

    I did a file health check and it says all the files are present and correct.


    Edit: Also the imagepaths and everything in the style is also correct as I checked.
  11. Mike

    Mike XenForo Developer Staff Member

  12. Rob

    Rob Well-Known Member

    Yup.... this is getting stranger by the minute.
    I'd rebuild the core data, just for good measure, but it's unlikely to be that.
  13. TheXboxCloud

    TheXboxCloud Active Member

    Well at least I know this is a legitimate issue. Seems to me as if cloudflare could be caching the files when I transferred them to the root directory.

    Hopefully I'll figure this out soon.
  14. Rob

    Rob Well-Known Member

    Ahh... good old cloudflare!!! This has caused me several problems before. Basically, I would purge all the cloudflare cache for starters. If this doesnt solve it, could you turn on developer mode inside cloudflare so we can at least see what your server is actually returning?
    Last edited: Sep 1, 2015
  15. rafass

    rafass Well-Known Member

    Go to your panel in CloudFlare and click in Caching:
    Screen shot 2015-09-01 at 4.32.10 PM.png
    Then purge everything 3 times:
    You will see this in the bottom:
    Screen shot 2015-09-01 at 4.33.41 PM.png
    Yeah, 3 times :coffee: I do that and it solve my issues many times :coffee:
    Last edited: Sep 1, 2015
  16. TheXboxCloud

    TheXboxCloud Active Member

    Yeah that was actually the first thing I did.

    I believe it's probably caching up the files from the file move. In which case purging the cache may not solve it.

    I'm going to re-upload some of the files and see what it does.

  17. TheXboxCloud

    TheXboxCloud Active Member

    Now I'm at a loss. Purging the cache, file health check seems good, even re-uploaded all the files through ftp.

    Not sure where to go from here. If anyone has an idea let me know.
  18. Rob

    Rob Well-Known Member

    enable developer mode on cloudflare..... thats the first thing. Secondly, hit /install and rebuild the core master data.
    See where we go from there :)

  19. TheXboxCloud

    TheXboxCloud Active Member

    The install options not working. If you mean /install/index.php it doesn't load.

    Neither does /install by itself.

    I have no idea what is causing this but im going to update the ticket as I continue to find a solution.
  20. Chris D

    Chris D XenForo Developer Staff Member

Share This Page