1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 I can't login as member

Discussion in 'Troubleshooting and Problems' started by Mish, Jan 4, 2013.

  1. Mish

    Mish Member

    I've just bought a 1.1.3 XF license and installation looks fine but now I can't login as member from forum homepage (I've tried with a couple of accounts). I f I acces from ACP everything is fine. If i register as new member and confirm the registration via email I will access to the forum and I'll be able to post and use it perfectly, but if I logout then I can't login again. The problem seems just from the homepage login, it redirect me to the same forum homepage without log me in, showing this url http://www.mysite.com/forum/index.php?login/login . Tested with Chrome and Firefox, clearing cache and cookies.
    I'm not an expert and I've read some posts about login issues in this forum, most of them are related to inconsistent links or timeout issues. I also found this suggestion http://xenforo.com/community/threads/users-not-staying-logged-in.18924/#post-243986 but I don't know if that is my case too and I'd like to ask help to people who know this better than me before I edit some file, I don't want to mess the forum up, so far it's everything by default installation, just added a first test thread and uploaded a translation file.
    Thank you in advance for your time.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Mish

    Mish Member

    Thank you for your reply Jake. I've checked the points in that thread:

    1) Not my case, this is not a disconnection related to idle, users just can't do the normal login, it's not about an unexpected logout after they logged in
    2) Looks weird because I didn't add any new link in the forum, so it's all by default (included forum structure) and it should work in this way I suppose. Anyway I tried to modify .htaccess with those lines to specify the directory, but nothing happens, same error
    3) I've checked, no proxy used by the server, my IP is matching
    4) I've tried to modify library/config.php as you wrote , but nothing happens, same error

    I'm pretty confused and I don't know what could be the problem at this point.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you give me a URL and admin login.
     
  5. Mish

    Mish Member

    Thank you very much Jake, I've just sent you all details in a conversation. Thank you very much for your time :)
     
  6. Mish

    Mish Member

    Just for the record, I solved this issue switching from a windows hosting space to a linux one :)
     

Share This Page