XF 1.5 HTML5 image uploader question

tommydamic68

Well-known member
#1
After upgrade to latest Xenforo version, the default settings for the HTML5 uploader have both options checked, should I leave it like that or...

Screen Shot 2017-01-17 at 9.21.54 PM.png
 
Last edited:

Chris D

XenForo developer
Staff member
#2
The HTML5 uploader will be used where possible. If it isn't possible (such as with older versions of XFMG and XFRM or other add-ons), then the Flash uploader will be used instead (if enabled).

If you have no desire to support the Flash uploader at all, you can feel free disable it, otherwise just leave it as it is.
 

Rudy

Well-known member
#3
I am clear on what the admin selections do.

Yet, when I go to my Preferences, here is what I see:

upload_2017-1-18_11-9-39.png

So is everyone still using the Flash uploader until they turn this option off? (If that were the case, nobody would even know this has changed, and everyone would still be using Flash unless they were told about this.)

Or, are they automatically using the HTML5 uploader unless they have an old non-HTML5-capable browser, regardless of this setting?

If someone unchecks this box, do they then get the HTML5 uploader or, like in previous versions, just a standard HTML upload dialog?

Or...is this a phrase that needs to be changed from "Flash" to "HTML5" to avoid confusion?

So yes, I'm confused now as to exactly what is happening, from the public side of the forum, regarding this setting in Preferences.
 

Chris D

XenForo developer
Staff member
#4
HTML5 uploader is enabled by default and should broadly be available automatically on all devices without any compatibility issues, hence it doesn't need a user preference to turn it on and off.

The Flash setting there applies only when the HTML5 uploader is not available for some reason, for example if the Admin has switched it off, or the add-on hasn't yet been updated to use the new uploader.
 

Mike

XenForo developer
Staff member
#5
For reference, that option was left because of the difficult and unknown status of add-ons and/or outdated templates. If you have no add-ons that interact with uploaders and updated templates, it doesn't need to be there. If you do, then you still potentially have the need for the option: there have been some situations where Flash is installed but broken, thus blocking uploads. If we removed the option, then either you wouldn't be able to switch the value if needed or the option would get disabled for everyone if they save their preferences, which comes back to things not being updated.

Edge cases yes, but it was considered and we felt the safest option was to leave the preference (for now) even if it doesn't generally apply.
 
Last edited:

tommydamic68

Well-known member
#7
Not sure if this is an issue or even has anything to do with the new HTML5 uploader/ flash setting. A member uploaded a video that had this, here is the video embedded code:
Code:
[MEDIA=veoh]1166384372gM3As5S[/MEDIA]
Screen Shot 2017-01-19 at 5.28.41 AM.png

Then once you clicked it to view video it just hung with a white screen.
Screen Shot 2017-01-19 at 5.30.20 AM.png
 
Last edited:
Top