1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 how to remove files associated with deleted resources?

Discussion in 'Troubleshooting and Problems' started by Kassierer, Apr 17, 2016.

  1. Kassierer

    Kassierer Member


    we use XenForo on a small webhosting package, but now hit the storage line with mp3 files that we offer to our members (recordings from our Sunday services). We use the Resource Manager to offer the files.

    No big deal at all, so I deleted the eldest entries in the Resource Manager (yes, I did a final delete), and I also deleted the associated posts in the forum where the resources are displayed.

    But it seems the associated files are still there (/internal_data/attachments/0). OK, I can remove them by hand, but I would suspect that XenForo should do that.

    And, yes, I manually started the hourly and daily clean-up processes, but the files are still there.

    What can I do (except delete the files manually)?
  2. Chris D

    Chris D XenForo Developer Staff Member

    Only files which are over 24 hours old will be cleaned up automatically and it will only delete a maximum of 1000 at a time. If more than 1000 have been deleted then it will require the Cron to run X more times until they're all cleaned.
    Kassierer likes this.
  3. Kassierer

    Kassierer Member

    Thanks for your fast reply.

    As I've deleted four resource entries, it should work on the first run.
  4. Kassierer

    Kassierer Member


    may I bring the topic up again?

    The files associated with the deleted resources have been removed, but I still have problems uploading files for new resources.

    Our webspace has 3.000 MB space, of which we currently use 2.200 MB. XenForo is 1.5.7, and the Resource Manager is 1.2.3.

    Uploading a 40 MB file starts as normal, after selecting the file the upload indicator is running, and after a while it stops, and the file section dialog is still there. I don't see any error message, and the server log doesn't show any error as well. The file in question is a mp3 file, which is an allowed file type (most of the files are mp3).

    What could be the reason for that kind of behavior?

    Thanks in advance!
  5. Chris D

    Chris D XenForo Developer Staff Member

    The AJAX indicator that stops is actually somewhat of a design issue. AJAX actions are generally supposed to be short lived, I think it only runs for around 5 seconds. If the action your performing takes longer than 5 seconds, it may appear as though progress has stopped, even though it hasn't.

    So if you have tried waiting for a considerable amount of time it could be a range of server related things.

    It could be the maximum execution timeout of PHP, or your webserver. It could be the maximum file size supported by PHP or your web server. It could be timeout values for MySQL being hit. There's a few PHP specific values that could have an impact, too, specifically post_max_size.

    I recommend contacting your host in the first instance as they may be able to check some of these values or see if there are any errors logged on the server that may be relevant.
  6. Kassierer

    Kassierer Member


    sorry for the delay. The problem is solved - our hoster had to adjust the maximum file size to be uploaded.
    It had worked before, but I switched the PHP version via the control panel - the old PHP version had adjustments to fit our normal resource file size.
    adwade likes this.

Share This Page