XF 1.5 Hosting company upgraded tp PHP 7.4.12 and that seems to have broken xf 1.5.21

It started with the forum displaying:
"A server error occurred. Please try again later."

Digging further, accessing /forums/admin.php shows
"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?
  1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
  2. include() in XenForo/Autoloader.php at line 119
  3. XenForo_Autoloader->autoload()
  4. spl_autoload_call() in XenForo/Visitor.php at line 520
  5. XenForo_Visitor->setVisitorLanguage() in XenForo/Visitor.php at line 471
  6. XenForo_Visitor::setup() in XenForo/Session.php at line 421
  7. XenForo_Session::startAdminSession() in XenForo/ControllerAdmin/Abstract.php at line 48
  8. XenForo_ControllerAdmin_Abstract->_setupSession() in XenForo/Controller.php at line 306
  9. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 368
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 152
  11. XenForo_FrontController->run() in /home3/weinarts/public_html/mwgl/forums/admin.php at line 13

looking at /forums/install/ redirects to /forums/install/index.php?upgrade/and shows

Server Error​

"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

  1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
  2. include() in XenForo/Autoloader.php at line 119
  3. XenForo_Autoloader->autoload()
  4. spl_autoload_call() in XenForo/Visitor.php at line 520
  5. XenForo_Visitor->setVisitorLanguage() in XenForo/Visitor.php at line 471
  6. XenForo_Visitor::setup() in XenForo/Install/Controller/Upgrade.php at line 50
  7. XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 306
  8. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 368
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 152
  10. XenForo_FrontController->run() in /home3/weinarts/public_html/mwgl/forums/install/index.php at line 18


Any suggestions for next steps?

Thanks.
 

Ozzy47

Well-known member
It depends which version of XF 1.5.

Only the newest versions will support PHP 7.2 and 7.3.

For 7.2 support you likely need a release after January 2018. For 7.3 support you need a release after January 2019.
 
Top