XF 1.5 Nothing is working anymore, seems to have broken forum ?

ungovernable

Active member
Everything was working fine yesterday and so last night i added a few addons and tested Elastic Search. Then after a few hours i noticed the whole forum is broken up but i don't understand what caused that. Now even without addons and with XF default template, everything is messed up.

Symptoms include:
- Everything javascript is broken. Lots of errors in the console
- Alerts aren't working anymore. Usually the menu shows up when hovering the mouse pointer over the buttons. Either the menus wont show up or they wont close and will stack on top of each others
- Quick reply isn't working anymore, the form isn't displayed

What i tried :
- I have reverted all recent changes (including hard deleting recent addons files)
- i disabled ALL addons (using config.php)
- i deleted elastic search and even set back the default template.
- tried checking recently modified files on the FTP to find if theres something wrong
- spent lot of hours with my server management company to try to find a solution
- Last server backup was just after the bug appeared so i couldn't restore a backup

Live forum: https://www.anarcho-punk.net/forums/music-punk-scene-subcultures.31/
If someone wants to help i can provide admin access to XenForo or root access to the server.

- XenForo 1.5.13
- PHP Version 5.5.38 + mysqli
- phpinfo() https://www.anarcho-punk.net/phpinfo.php





 

Chris D

XenForo developer
Staff member
Someone has either edited a template or an add-on has added this into the HTML:
Code:
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js"></script>
That being added means there's now a conflict between this version of jQuery that has been added vs. the version of jQuery we include. If you have not added this yourself, then you will need to disable each add-on until you find the cause. If you have added yourself, remove this line and all should go back to normal.
 

ungovernable

Active member
Thanks for the fast reply.

Currently all addons are disabled using hardcoded config.php variable, so addons shouldn't be interferring
Code:
$config['enableListeners'] = false;
If i search templates for "jquery" i get 16 results. Where is the official XenForo jquery in the templates ? Just to make sure i don't remove this one. I suppose it's in page_container_js_head ?

 

Tracy Perry

Well-known member
Instead of searching on the generic jquery, search on the string that Chris provided to you
ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js
 

ungovernable

Active member
Instead of searching on the generic jquery, search on the string that Chris provided to you
ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js
I did, but i get no result in templates. And all addons are disabled.

In my template the only jquery code found looks like this:
Code:
<script src="{$jQuerySource}"></script>
 

Chris D

XenForo developer
Staff member
Disabling listeners only really disables code related events from running. It doesn't affect template edits or template modifications.

Even rather than searching as Tracy has said, you need to disable all add ons from the add on list in the Admin CP.

There's a button that will disable them all en masse and another button will appear so you can re-enable them all if the problem persists.

If the problem is solved by disabling all add ons, then you will need to enable each one by one until the problem comes back.
 

Tracy Perry

Well-known member
It may not be in a template itself but in a template modification and I'm not sure if the search would catch it there or not.
 

ungovernable

Active member
ok so investigating the jquery code provided by Chris it seems to be in the middle of a CSS code coming from addon "Scoll progress bar"

Code:
<script>

(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-60995319-4', 'auto');
ga('send', 'pageview');

</script>
<script src="js/jquery/jquery-1.11.0.min.js"></script>
<script src="js/xenforo/xenforo.js?_v=2733709c"></script>

<script>
XenForo.rellect = XenForo.rellect || {};
XenForo.rellect.FaviconExcluded = [];
XenForo.rellect.FaviconExcluded[0] = 1;XenForo.rellect.FaviconExcluded[2] = 1;XenForo.rellect.FaviconExcluded[3] = 1;
</script>

<style>

.scrollindicator{
width: 100%;
height: 7px; /* height of progress bar */
display: block;
background: white;
left: 0;
: 0; /* dock progress bar to bottom of page (change to "top" for top instead) */
cursor: pointer;
position: fixed;
z-index: 1000000;
visibility: hidden;
-webkit-transition: height .2s ease;
transition: height .2s ease;
}

.scrollprogress{
position: absolute;
width: 100%;
height: 100%;
background: ; /* background color of progress bar */
-webkit-transform: translate3d(-100%,0,0);
transform: translate3d(-100%,0,0);
=-webkit-transition: -webkit-transform .4s ease;
transition: transform .4s ease; /* animate progress bar? Remove to disable */
}
</style>

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js"></script>
There was still some data from the addon left on the forum even if i had all addons disabled. I deleted everything and it seems to have fixed the issue !
 

Chris D

XenForo developer
Staff member
You didn't have all add ons disabled. You just had code event listeners disabled. Disabling listeners is really only something you do if there's no ability to disable add ons properly, such as a code related error preventing access to the Admin CP.
 
Top