1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Home Screen

Discussion in 'XenForo Questions and Support' started by Brian Woody, Jun 20, 2016.

  1. Brian Woody

    Brian Woody Member

    Hi, I'm trying to figure out how to achieve something like what www.testyourmight.com uses, where there is a home screen that displays posts and other general info, but it's not a separate site; it's all within the Xenforo software. Xenforo is currently installed in my root directory (so my board is located at https://streamauthority.com). Thanks!
     
  2. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    They are using XenPorta 2 by @Jaxel.
     
    Brian Woody likes this.
  3. Brian Woody

    Brian Woody Member

    Gotcha, but how do they have a home page that's still within the site. Currently my board is at my base URL (streamauthority.com). They've got their base URL (testyourmight.com) set as the Home page, and their board is set to /forums. I see that Xenporta allows you to publish content like that, but I don't see anything about it allowing you to create a homepage and then set your forums to homepage/forums.
     
  4. Jaxel

    Jaxel Well-Known Member

  5. Brogan

    Brogan XenForo Moderator Staff Member

    The default route for forums is /forums.

    With a portal add-on, you change the index route from /forums to something else, which is how the the home page appears at the domain root in place of the forum list.
     
    Brian Woody likes this.
  6. Brian Woody

    Brian Woody Member

    @Jaxel Ok, thanks for the help! I'll check those out.

    @Brogan I'm not sure I understand. My route for forums is currently my homepage, with no /forums. I'm completely new to web development, so I'm not sure if I installed it incorrectly or changed some setting, but right now the Forums tab on my Xenforo installation is just https://streamauthority.com.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    The Index Page Route in the options will be set to forums/:

    upload_2016-6-20_16-1-21.png

    That removes that part of the URL from the index page.

    Change it to members/ and then load the forum index and members page to see how it works.
     
    Brian Woody likes this.
  8. Brian Woody

    Brian Woody Member

    Gotcha, thanks! I'll give that a shot right now.
     
  9. Brian Woody

    Brian Woody Member

    @Brogan Ok, perfect, so I changed it to home/ and that seems to be working. Going to streamauthority.com takes me to the Home tab, the Forums tab is /forums, Member is /members. This is perfect. So the Home tab is currently generating "Error - Not Found", which I understand. So I can use Xenporta to create the content for the Home page?
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    You would enter the route defined in the add-on, it could be home/ or it could be another route but whatever it is, it would become the index page and would load at the domain root.
     
    Brian Woody likes this.
  11. Brian Woody

    Brian Woody Member

    Ok, that makes sense. Thanks for the quick replies!
     

Share This Page